Sling
  1. Sling
  2. SLING-2256

Make The SlingDavExServlet configurable

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: JCR DavEx 1.1.0
    • Component/s: JCR
    • Labels:
      None

      Description

      Does anybody mind if the properties of the davex servlet are made configurable?

      @Component(label = "%dav.name", description = "%dav.description", metatype=true)

      And if not, can anybody apply that change?

      I have the urgent need as we have disabled the anonymous user and
      without him the
      RepositoryDescriptors can't be fetched by the jcr2spi layer which
      results in a read only davex access.

      This can be cirumvented by setting the init.missing-auth-mapping
      parameter on the davex servlet.

        Activity

        Justin Edelson added a comment -

        done in r1189896

        ONLY the init.missing-auth-mapping parameter is configurable. If you need other parameters to be configurable, please reopen with those details.

        Justin Edelson added a comment -

        reverted commit in r1190409

        Markus - it sounds like the issue is more about accessing DavEx when the anonymous user is disabled. Is that accurate?

        Markus Joschko added a comment -

        No. I tested the most recent davexservlet with the anonymous user enabled and I can only get a read+write repository via davex if I explicitly add -/server to the list of urls that do NOT need authentication. Otherwise I am left with a read only repository (where I then can correctly login).

        Would be glad if somebody else could verify that behavior. For me it looks like a major bug in the davexservlet but I also can't imagine, that nobody apart from us is using davex since august and I haven't heard any other complaints.

        Justin Edelson added a comment -

        This has been obviated by SLING-2274


          People

          • Assignee:
            Justin Edelson
            Reporter:
            Markus Joschko
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development