Sling
  1. Sling
  2. SLING-1794

ConfigInstallTest fails semi-randomly: Configuration is still present

    Details

    • Type: Bug Bug
    • Status: Reopened
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Installer
    • Labels:

      Description

      -------------------------------------------------------------------------------
      Test set: org.apache.sling.installer.it.ConfigInstallTest
      -------------------------------------------------------------------------------
      Tests run: 3, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 17.044 sec <<< FAILURE!
      testDeferredConfigInstall [felix](org.apache.sling.installer.it.ConfigInstallTest) Time elapsed: 10.072 sec <<< FAILURE!
      java.lang.AssertionError: Config must be removed once ConfigurationAdmin restarts: Configuration is still present (ConfigInstallTest.deferred.1285097628299)
      at org.junit.Assert.fail(Assert.java:74)
      at org.apache.sling.installer.it.OsgiInstallerTestBase.waitForConfiguration(OsgiInstallerTestBase.java:246)
      at org.apache.sling.installer.it.ConfigInstallTest.testDeferredConfigInstall(ConfigInstallTest.java:149)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.ops4j.pax.exam.junit.extender.impl.internal.CallableTestMethodImpl.injectContextAndInvoke(CallableTestMethodImpl.java:143)
      at org.ops4j.pax.exam.junit.extender.impl.internal.CallableTestMethodImpl.call(CallableTestMethodImpl.java:105)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.ops4j.pax.exam.rbc.internal.RemoteBundleContextImpl.remoteCall(RemoteBundleContextImpl.java:80)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:305)
      at sun.rmi.transport.Transport$1.run(Transport.java:159)
      at java.security.AccessController.doPrivileged(Native Method)
      at sun.rmi.transport.Transport.serviceCall(Transport.java:155)
      at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:535)
      at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:790)
      at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:649)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)

      1. stdio.txt
        3.09 MB
        Bertrand Delacretaz

        Issue Links

          Activity

          Bertrand Delacretaz added a comment -

          Still regular failures at http://ci.apache.org/builders/sling-trunk, my last fixes haven't helped.

          Bertrand Delacretaz added a comment -

          Improved synchronization by waiting for installer events in http://svn.apache.org/r1547444, looks better on my box but I still get rare failures. Haven't found the exact cause yet.

          Bertrand Delacretaz committed 1547444 (2 files)
          Reviews: none

          SLING-1794 - improve synchronization and split between deferred install and remove tests, trying to avoid semi-random failures (haven't found the root cause yet)

          Bertrand Delacretaz made changes -
          Summary ConfigInstallTest fails: Config must be removed once ConfigurationAdmin restarts: Configuration is still present ConfigInstallTest fails semi-randomly: Configuration is still present
          Bertrand Delacretaz made changes -
          Link This issue blocks SLING-3234 [ SLING-3234 ]
          Bertrand Delacretaz made changes -
          Attachment stdio.txt [ 12613637 ]
          Bertrand Delacretaz made changes -
          Labels it,intermittent
          Bertrand Delacretaz made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Assignee Robert Munteanu [ rombert ] Bertrand Delacretaz [ bdelacretaz ]
          Bertrand Delacretaz added a comment - - edited

          Just saw this again on a buildbot build: http://ci.apache.org/builders/sling-trunk/builds/5/steps/compile/logs/stdio

          I'll attach the logs, which indicate that the config is indeed deleted (15:46:34.982), but the test still times out after 5 seconds (15:46:39.995) thinking the config still exists. No idea why, and it looks like this happens quite rarely now.

          Robert Munteanu made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Robert Munteanu added a comment -
          Robert Munteanu committed 1503746 (1 file)
          Reviews: none

          SLING-1794 - ConfigInstallTest fails: Config must be removed once
          ConfigurationAdmin restarts: Configuration is still present

          Slightly increase the timeout when running tests, to help them pass
          consistently on Jenkins.

          Robert Munteanu committed 1503745 (1 file)
          Reviews: none

          SLING-1794 - ConfigInstallTest fails: Config must be removed once
          ConfigurationAdmin restarts: Configuration is still present

          Add timestamps to the IT log output to differentiate between test
          failures and timing issues.

          Robert Munteanu made changes -
          Priority Critical [ 2 ] Major [ 3 ]
          Robert Munteanu made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Assignee Robert Munteanu [ rombert ]
          Robert Munteanu added a comment -

          This still happens in some Jenkins builds, for instance https://builds.apache.org/job/sling-trunk-1.6/org.apache.sling$org.apache.sling.installer.it/1738/testReport/junit/org.apache.sling.installer.it/ConfigInstallTest/testDeferredConfigInstall/ . The logging output indicates that the configuration is removed, so this is probably a timing issue.

          Gavin made changes -
          Workflow re-open possible,doc-test-required [ 12789821 ] no-reopen-closed,doc-test-required [ 12792700 ]
          Gavin made changes -
          Workflow no-reopen-closed,doc-test-required [ 12767755 ] re-open possible,doc-test-required [ 12789821 ]
          Gavin made changes -
          Workflow Copy of no-reopen-closed,doc-test-required [ 12764978 ] no-reopen-closed,doc-test-required [ 12767755 ]
          Gavin made changes -
          Workflow no-reopen-closed,doc-test-required [ 12521155 ] Copy of no-reopen-closed,doc-test-required [ 12764978 ]
          Justin Edelson added a comment -

          Be sure to set your PermGen to 512MB. This has basically stabilized the build for me.

          Andreas Kuckartz made changes -
          Field Original Value New Value
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Resolved [ 5 ]
          Andreas Kuckartz added a comment -

          I can not reproduce the error I have reported.

          Andreas Kuckartz added a comment -

          I just tried "mvn -s /dev/null clean install" again (without svn update before doing so) and it was successful.

          The tests and their results seem to be somewhat unpredictable...

          Andreas Kuckartz added a comment -

          Now I get lots of other failed tests (for "mvn -s /dev/null clean install"):

          testIndex(org.apache.sling.launchpad.webapp.integrationtest.InitialContentTest)
          testRootRedirectProperty(org.apache.sling.launchpad.webapp.integrationtest.InitialContentTest)
          testInitialContentA(org.apache.sling.launchpad.webapp.integrationtest.InitialContentTest)
          testInitialContentB(org.apache.sling.launchpad.webapp.integrationtest.InitialContentTest)
          testWebServerRoot(org.apache.sling.launchpad.webapp.integrationtest.HttpPingTest)
          testCounters(org.apache.sling.launchpad.webapp.integrationtest.FiltersTest)
          testForcedLogin(org.apache.sling.launchpad.webapp.integrationtest.login.AuthRequestLoginTest)

          org.apache.sling.launchpad.testing.TestAll.txt begins with these lines (I did not find a specific log file for org.apache.sling.launchpad.webapp.integrationtest.InitialContentTest):

          -------------------------------------------------------------------------------
          Test set: org.apache.sling.launchpad.testing.TestAll
          -------------------------------------------------------------------------------
          Tests run: 382, Failures: 7, Errors: 0, Skipped: 0, Time elapsed: 310.095 sec <<< FAILURE!
          testIndex(org.apache.sling.launchpad.webapp.integrationtest.InitialContentTest) Time elapsed: 0.051 sec <<< FAILURE!
          junit.framework.AssertionFailedError: Expected status 200 for http://localhost:38786/index.html (content=<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
          <html>
          <head>
          <title>404 No resource found</title>
          </head>
          <body>
          <h1>No resource found (404)</h1>
          <p>The requested URL /index.html resulted in an error in org.apache.sling.servlets.resolver.internal.defaults.DefaultErrorHandlerServlet.</p>
          <h3>Request Progress:</h3>
          <pre>
          0 (2010-09-22 09:41:03) TIMER_START

          {Request Processing}

          0 (2010-09-22 09:41:03) COMMENT timer_end format is

          {<elapsed msec>,<timer name>}

          <optional message>
          0 (2010-09-22 09:41:03) LOG Method=GET, PathInfo=/index.html
          0 (2010-09-22 09:41:03) TIMER_START

          {ResourceResolution}

          21 (2010-09-22 09:41:03) TIMER_END

          {21,ResourceResolution}

          URI=/index.html resolves to Resource=NonExistingResource, path=/index.html
          21 (2010-09-22 09:41:03) LOG Resource Path Info: SlingRequestPathInfo: path='/index.html', selectorString='null', extension='html', suffix='null'
          21 (2010-09-22 09:41:03) TIMER_START

          {ServletResolution}

          21 (2010-09-22 09:41:03) TIMER_START

          {resolveServlet(NonExistingResource, path=/index.html)}

          23 (2010-09-22 09:41:03) TIMER_END

          {2,resolveServlet(NonExistingResource, path=/index.html)}

          Using servlet org.apache.sling.servlets.get.DefaultGetServlet
          23 (2010-09-22 09:41:03) TIMER_END

          {2,ServletResolution}

          URI=/index.html handled by Servlet=org.apache.sling.servlets.get.DefaultGetServlet
          23 (2010-09-22 09:41:03) LOG Applying Requestfilters
          23 (2010-09-22 09:41:03) LOG Calling filter: org.apache.sling.engine.impl.debug.RequestProgressTrackerLogFilter
          23 (2010-09-22 09:41:03) LOG Calling filter: org.apache.sling.launchpad.testservices.filters.NoPropertyFilter
          23 (2010-09-22 09:41:03) LOG Calling filter: org.apache.sling.launchpad.testservices.filters.SlingFilter
          23 (2010-09-22 09:41:03) TIMER_START

          {org.apache.sling.servlets.get.DefaultGetServlet#0}

          23 (2010-09-22 09:41:03) TIMER_END

          {0,org.apache.sling.servlets.get.DefaultGetServlet#0}

          23 (2010-09-22 09:41:03) TIMER_START

          {handleError:status=404}

          24 (2010-09-22 09:41:03) TIMER_END

          {1,handleError:status=404}

          Using handler org.apache.sling.servlets.resolver.internal.defaults.DefaultErrorHandlerServlet
          24 (2010-09-22 09:41:03) TIMER_END

          {24,Request Processing}

          Dumping SlingRequestProgressTracker Entries
          </pre>
          <hr>
          <address>ApacheSling/2.1 (Java HotSpot(TM) 64-Bit Server VM 1.6.0_21; Linux 2.6.32-trunk-amd64 amd64)</address>
          </body>
          </html>
          ) expected:<200> but was:<404>
          at junit.framework.Assert.fail(Assert.java:47)
          ...

          BTW: The log produced by
          $ mvn -Dtest=ConfigInstallTest install
          did not seem to be very helpful:

          andreas@lenny:~/sling$ mvn -Dtest=ConfigInstallTest install
          [INFO] Scanning for projects...
          [INFO] Reactor build order:
          [INFO] Apache Sling (Parent)
          [INFO] Apache Sling Maven Plugin to create Jackrabbit OCM descriptors
          [INFO] Apache Sling API
          [INFO] Apache Sling Scripting Implementation API
          [INFO] Apache Sling Dynamic Class Loader Support
          [INFO] Apache Sling Scripting JSP Support
          [INFO] Apache Sling Maven Plugin for Compiling JSP Sources into Bundles
          [INFO] Apache Sling Repository API Bundle
          [INFO] Apache Sling Commons OSGi support
          [INFO] Apache Sling Adapter Manager Implementation
          [INFO] Apache Sling Testing Utilities
          [INFO] Apache Sling JSON Library
          [INFO] Apache Sling Maven Plugin for Supporting Bundle Development
          [INFO] Apache Sling Launchpad Base
          [INFO] Apache Sling Launchpad Maven Plugin
          [INFO] Sling Launchpad Standalone Archetype
          [INFO] Sling Launchpad Webapp Archetype
          [INFO] Sling Resources Archetype
          [INFO] Sling Servlet Archetype
          [INFO] Apache Sling OSGi LogService Implementation
          [INFO] Apache Sling MIME type mapping support
          [INFO] Apache Sling Thread Support
          [INFO] Apache Sling Scheduler Support
          [INFO] Apache Sling Authentication Service
          [INFO] Apache Sling JCR Base Bundle
          [INFO] Apache Sling Jackrabbit Embedded Repository
          [INFO] Apache Sling OpenID Authentication
          [INFO] Apache Sling Form Based Authentication Handler
          [INFO] Apache Sling Authentication Selector
          [INFO] Apache Sling Settings
          [INFO] Apache Sling Engine Implementation
          [INFO] Apache Sling JCR ClassLoader
          [INFO] Apache Sling Initial Content Loader
          [INFO] Apache Sling JCR Resource Resolver
          [INFO] Apache Sling Default POST Servlets
          [INFO] Apache Sling Jackrabbit UserManager Support
          [INFO] Apache Sling Jackrabbit JSR-283 Access Control Manager Support
          [INFO] Apache Sling Object Content Mapping
          [INFO] Apache Sling Simple WebDAV Access to repositories
          [INFO] Apache Sling DavEx Access to repositories
          [INFO] Apache Sling JCR WebConsole Bundle
          [INFO] Apache Sling Servlet Resolver
          [INFO] Apache Sling Default GET Servlets
          [INFO] Apache Sling Scripting Core implementation
          [INFO] Apache Sling Scripting JavaScript Support
          [INFO] Apache Sling JSP Tag Library
          [INFO] Apache Sling Bundle Resource Provider
          [INFO] Apache Sling Event Support
          [INFO] Apache Sling Filesystem Resource Provider
          [INFO] Apache Sling Thread Dumper
          [INFO] Apache Sling Web Console Branding
          [INFO] Apache Sling Web Console Security Provider
          [INFO] Apache Sling Groovy Extensions
          [INFO] Apache Sling Explorer
          [INFO] Apache Sling Installer
          [INFO] Apache Sling File Installer
          [INFO] Apache Sling JCR Installer
          [INFO] Apache Sling Installer Integration Tests
          [INFO] Apache Sling Launchpad Content
          [INFO] Apache Sling Launchpad Application Builder
          [INFO] Apache Sling Launchpad Testing Services
          [INFO] Apache Sling Launchpad Testing Services WAR
          [INFO] Apache Sling Integration Tests
          [INFO] Apache Sling Launchpad Testing
          [INFO] Apache Sling (Builder)
          [INFO] ------------------------------------------------------------------------
          [INFO] Building Apache Sling (Parent)
          [INFO] task-segment: [install]
          [INFO] ------------------------------------------------------------------------
          [INFO] [enforcer:enforce

          {execution: enforce-java}

          ]
          [INFO] Setting property: classpath.resource.loader.class => 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.
          [INFO] Setting property: velocimacro.messages.on => 'false'.
          [INFO] Setting property: resource.loader => 'classpath'.
          [INFO] Setting property: resource.manager.logwhenfound => 'false'.
          [INFO] [remote-resources:process

          {execution: default}

          ]
          [INFO] [antrun:run

          {execution: default}

          ]
          [INFO] Executing tasks
          [echo] **************** WARNING (SLING-443/SLING-1782) ******************************
          [echo] On most platforms, you'll get OutOfMemoryErrors when building unless you set
          [echo] on 32bit platforms: MAVEN_OPTS="-Xmx256M -XX:MaxPermSize=256M", see SLING-443
          [echo] on 64bit platforms: MAVEN_OPTS="-Xmx512M -XX:MaxPermSize=512M", see SLING-1782
          [echo] ******************************************************************************
          [INFO] Executed tasks
          [INFO] [site:attach-descriptor

          {execution: default-attach-descriptor}

          ]
          [INFO] Preparing source:jar
          [WARNING] Removing: jar from forked lifecycle, to prevent recursive invocation.
          [INFO] [enforcer:enforce

          {execution: enforce-java}

          ]
          [INFO] [source:jar

          {execution: attach-sources}

          ]
          [INFO] [ianal:verify-legal-files

          {execution: default}

          ]
          [INFO] [install:install

          {execution: default-install}

          ]
          [INFO] Installing /home/andreas/sling/parent/pom.xml to /home/andreas/.m2/repository/org/apache/sling/sling/10-SNAPSHOT/sling-10-SNAPSHOT.pom
          [INFO] ------------------------------------------------------------------------
          [INFO] Building Apache Sling Maven Plugin to create Jackrabbit OCM descriptors
          [INFO] task-segment: [install]
          [INFO] ------------------------------------------------------------------------
          [INFO] [enforcer:enforce

          {execution: enforce-java}

          ]
          [INFO] [plugin:descriptor

          {execution: default-descriptor}

          ]
          [INFO] Using 'UTF-8' encoding to read mojo metadata.
          [INFO] Applying mojo extractor for language: java
          [INFO] Mojo extractor for language: java found 1 mojo descriptors.
          [INFO] Applying mojo extractor for language: bsh
          [INFO] Mojo extractor for language: bsh found 0 mojo descriptors.
          [INFO] [remote-resources:process

          {execution: default}

          ]
          [INFO] [resources:resources

          {execution: default-resources}

          ]
          [INFO] Using 'UTF-8' encoding to copy filtered resources.
          [INFO] Copying 0 resource
          [INFO] Copying 3 resources
          [INFO] [antrun:run

          {execution: default}

          ]
          [INFO] Executing tasks
          [echo] ********************** WARNING (SLING-443) **********************************
          [echo] On most platforms, you'll get OutOfMemoryErrors when building unless you set
          [echo] MAVEN_OPTS="-Xmx256M -XX:MaxPermSize=128M", see SLING-443.
          [echo] *****************************************************************************
          [INFO] Executed tasks
          [INFO] [compiler:compile

          {execution: default-compile}

          ]
          [INFO] Nothing to compile - all classes are up to date
          [INFO] [resources:testResources

          {execution: default-testResources}

          ]
          [INFO] Using 'UTF-8' encoding to copy filtered resources.
          [INFO] skip non existing resourceDirectory /home/andreas/sling/maven/maven-jcrocm-plugin/src/test/resources
          [INFO] Copying 3 resources
          [INFO] [compiler:testCompile

          {execution: default-testCompile}

          ]
          [INFO] No sources to compile
          [INFO] [surefire:test

          {execution: default-test}

          ]
          [INFO] Surefire report directory: /home/andreas/sling/maven/maven-jcrocm-plugin/target/surefire-reports

          -------------------------------------------------------
          T E S T S
          -------------------------------------------------------
          There are no tests to run.

          Results :

          Tests run: 0, Failures: 0, Errors: 0, Skipped: 0

          [INFO] ------------------------------------------------------------------------
          [ERROR] BUILD FAILURE
          [INFO] ------------------------------------------------------------------------
          [INFO] No tests were executed! (Set -DfailIfNoTests=false to ignore this error.)

          Andreas Kuckartz added a comment -

          Java(TM) SE Runtime Environment (build 1.6.0_21-b06)
          Java HotSpot(TM) 64-Bit Server VM (build 17.0-b16, mixed mode)
          64 bit Debian

          Carsten Ziegeler added a comment -

          The second error in the log is fine as it is expected - a bundle is installed during the tests which requires another bundle that's currently missing

          Can you add some more details about your environment please? And set the pax.exam.log.level property in the it pom.xml to DEBUG and then attach the log output? You can just run the failing test with "mvn -Dtest=ConfigInstallTest install

          Andreas Kuckartz added a comment -

          I also found this in the logs:

          21.09.2010 21:34:55.889 ERROR [FelixDispatchQueue] osgi-installer-needsB FrameworkEvent ERROR (org.osgi.framework.BundleException: Unresolved constraint in bundle osgi-installer-needsB [14]: package; (&(package=org.apache.sling.installer.it.a)(version>=1.0.0))) org.osgi.framework.BundleException: Unresolved constraint in bundle osgi-installer-needsB [14]: package; (&(package=org.apache.sling.installer.it.a)(version>=1.0.0))
          at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3263)
          at org.apache.felix.framework.Felix.startBundle(Felix.java:1597)
          at org.apache.felix.framework.Felix$RefreshHelper.restart(Felix.java:4280)
          at org.apache.felix.framework.Felix.refreshPackages(Felix.java:3415)
          at org.apache.felix.framework.PackageAdminImpl.run(PackageAdminImpl.java:329)
          at java.lang.Thread.run(Thread.java:619)

          Andreas Kuckartz created issue -

            People

            • Assignee:
              Bertrand Delacretaz
              Reporter:
              Andreas Kuckartz
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:

                Development