Sling
  1. Sling
  2. SLING-1272

Intermittent integration test failures

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Since I have applied the SLING-966 patches this morning, the integration tests intermittently fail: Sometimes tests fail at seemingly random patterns. Sometimes all tests succeed.

      Currently investigating, what may be the cause of these problems.

        Issue Links

          Activity

          Felix Meschberger created issue -
          Felix Meschberger committed 896660 (1 file)
          Reviews: none

          SLING-1272 Update dependency to JCR Base bundle and add dependency to Jackrabbit API library

          Felix Meschberger added a comment -

          It looks like the version dependency to the JCR Base bundle must be updated to a more recent version in the Jackrabbit Server bundle. Done in Rev. 896660

          This solves the integration failure issues on my platform.

          I suspect the problems to be related to the older default setting for session pooling which seems to break with Jackrabbit 1.6...

          Felix Meschberger added a comment -

          Since with the new setup and default disabled session pooling this works.

          I suspect the new authentication mechanism doesn't cope well with session pooling and thus this should be removed (also for other reasons). See SLING-1283 for details.

          Felix Meschberger made changes -
          Field Original Value New Value
          Link This issue is related to SLING-1283 [ SLING-1283 ]
          Carsten Ziegeler added a comment -

          As the test pass I think we can close this

          Carsten Ziegeler made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Carsten Ziegeler made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Gavin made changes -
          Workflow no-reopen-closed,doc-test-required [ 12486147 ] Copy of no-reopen-closed,doc-test-required [ 12763896 ]
          Gavin made changes -
          Workflow Copy of no-reopen-closed,doc-test-required [ 12763896 ] no-reopen-closed,doc-test-required [ 12765777 ]
          Gavin made changes -
          Workflow no-reopen-closed,doc-test-required [ 12765777 ] re-open possible,doc-test-required [ 12787555 ]
          Gavin made changes -
          Workflow re-open possible,doc-test-required [ 12787555 ] no-reopen-closed,doc-test-required [ 12790442 ]

            People

            • Assignee:
              Felix Meschberger
              Reporter:
              Felix Meschberger
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development