Uploaded image for project: 'Slider'
  1. Slider
  2. SLIDER-1012

Export tomcat app servers and quicklinks

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Slider 0.81
    • Fix Version/s: Slider 0.91
    • Component/s: app-package
    • Labels:
      None

      Description

      Now that
      https://issues.apache.org/jira/browse/SLIDER-809 allows tomcat running in the YARN, but Tomcat app package should export the servers and quicklink.

        Activity

        elserj Josh Elser added a comment -

        Hey, fengyongshe. I'm super happy to hear that you tried out the tomcat app-package. Have you been having success playing around with the code on SLIDER-809? What do you see the path forward to get these patches into the codebase?

        fengyongshe fengyongshe added a comment -

        We have used tomcat app as a service in our running yarn cluster for some time.The patch not based on the codebase,but it only add a few lines,so i didn't rebuilt the patch。

        fengyongshe fengyongshe added a comment -

        About "Reference external WAR file ",we add a command to upload the war file to tomcat webApps dir , this May be some help to you.

        elserj Josh Elser added a comment -

        Very much so. Seeing your comments made me think that I really need to finish up the code and get it committed. I saw that dynamically specifying a WAR file was the last task I had outstanding. I would be curious to hear how you implemented it and if it is easy to use.

        fengyongshe fengyongshe added a comment -

        We realized a uploadFile command for containers to upload file to specify dir.
        eg:
        slider upload demo-tomcat --input /user/hadoop/.slider/data/app.war --containers container_1437029480626_0007_01_000002 --components TOMCAT
        It is a tempary way to resolve the problem。
        We can use https://issues.apache.org/jira/browse/SLIDER-664 ,but the jira is not resolved。
        by the way,we are working on it.

        elserj Josh Elser added a comment -

        We realized a uploadFile command for containers to upload file to specify dir.
        eg:
        slider upload demo-tomcat --input /user/hadoop/.slider/data/app.war --containers container_1437029480626_0007_01_000002 --components TOMCAT
        It is a tempary way to resolve the problem。

        Interesting. What does this command accomplish that wouldn't be covered by referencing a specific HDFS path to a file in the app_config.json?

        fengyongshe fengyongshe added a comment -

        Yes, use site.global.hdfs_app_dir configured in the app_config to save the uploaded war file. when tomcat restart ,get the war file from hdfs .

        stevel@apache.org Steve Loughran added a comment -

        targeting 0.91

        shenyinjie Shen Yinjie added a comment -

        +1

        elserj Josh Elser added a comment -

        I tried out this patch and it doesn't appear like it works as intended. It has the correct host name, but not the substituted port.

        {"description":"QuickLinks","updated":0,"entries":{"HTTP":"http://hw10447.local:${site.global.listen_port}"},"empty":false}
        

        I can also see in the SliderAM log:

        Preparing to publish. Key tomcat.http_port and Value hw10447.local:58138
        

        But I don't see this actually getting exported. I will try to look into this some more to figure out what is possible.

        jira-bot ASF subversion and git services added a comment -

        Commit c5f7ff9414cc59899fa9f6061fcdb1c1c3816441 in incubator-slider's branch refs/heads/develop from Josh Elser
        [ https://git-wip-us.apache.org/repos/asf?p=incubator-slider.git;h=c5f7ff9 ]

        SLIDER-1012 Modify server and quicklinks for Tomcat (fengyongshe)

        elserj Josh Elser added a comment -

        I applied (a slightly tweaked version of) your patch, fengyongshe. Thanks again!

        If you get a chance, I'd love to get your feedback on the app-package as committed. Looking forward to hearing from you again later.

        fengyongshe fengyongshe added a comment -

        I'm happy,the patch is helpful.

        jira-bot ASF subversion and git services added a comment -

        Commit 0992e85500239d88f77cbd76f142b1daf02d5219 in incubator-slider's branch refs/heads/develop from Steve Loughran
        [ https://git-wip-us.apache.org/repos/asf?p=incubator-slider.git;h=0992e85 ]

        Merge branch 'develop' of https://git-wip-us.apache.org/repos/asf/incubator-slider into develop


          People

          • Assignee:
            fengyongshe fengyongshe
            Reporter:
            fengyongshe fengyongshe
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development