Spatial Information Systems
  1. Spatial Information Systems
  2. SIS-27

Update sis-parent/pom.xml compile target to 1.6

    Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.2-incubating
    • Fix Version/s: 0.2-incubating
    • Component/s: Build process
    • Labels:
      None
    • Environment:

      os-x

      Description

      sis-parent/pom.xml contains a maven.compile.target of java 1.5
      would be good to update it to 1.6

      1. SIS-27.patch
        0.4 kB
        patrick o'leary

        Activity

        patrick o'leary created issue -
        patrick o'leary added a comment -

        Java 1.5 is now deprecated from most modern os's and throws a

        running mvn clean install on a new system will throw

        Caused by: org.apache.maven.plugin.CompilationFailureException: Compilation failure
        Failure executing javac, but could not parse the error:
        javac: source release 1.6 requires target release 1.6

        As java 1.5 is usually not installed, and sis-parent/pom.xml has a maven.compile.target of 1.5
        updating this to 1.6 resolves the problem, since the source code is already 1.6 based makes sense to update the target as well.

        patrick o'leary added a comment -

        Update sis-parent/pom.xml maven.compile.target to 1.6

        patrick o'leary made changes -
        Field Original Value New Value
        Attachment SIS-27.patch [ 12467304 ]
        Chris A. Mattmann made changes -
        Assignee patrick o'leary [ pjaol ] Chris A. Mattmann [ chrismattmann ]
        Chris A. Mattmann made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Chris A. Mattmann added a comment -
        • patch applied in r1160526. Thanks Patrick!
        Chris A. Mattmann made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Chris A. Mattmann
            Reporter:
            patrick o'leary
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development