Uploaded image for project: 'Shiro'
  1. Shiro
  2. SHIRO-826

HTTP 400 with encoded umlauts in URL

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Not A Bug
    • 1.7.1
    • None
    • None

    Description

      I've updated shiro from version 1.4.2 to 1.7.1.

       

      I have an rest-endpoint with an Pathvariable:

      @RestController
      @RequestMapping(value = "/inspektor/verjaehrungs-agent")
      @Slf4j
      public class MyRestController    
      
          @GetMapping("/profile/{name}")
          public Profile getProfile(@PathVariable final String name) {
              return service.getProfile(name);
          }
      

      When requesting with the Pathvariable name "Test 123" everything works fine. 

      When requesting with the Pathvariable name "Test ö" I'm getting an HTTP 400.

      This error occurs also, when I encode the Pathvariable to "TEST%20%C3%B6".

       

      Before the update, everything was fine.

      Attachments

        1. debug.log
          105 kB
          Sita Geßner
        2. error-request-with-umlauts.png
          23 kB
          Sita Geßner
        3. localhost_access_log.2021-07-19.txt
          8 kB
          Sita Geßner
        4. success-request-without-umlauts.png
          22 kB
          Sita Geßner

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            sgessner Sita Geßner
            Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment