Shiro
  1. Shiro
  2. SHIRO-73

Add Authentication Caching to AuthenticatingRealm

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Any

      Description

      Stateless clients would benefit from an authentication cache.

      For example if a stateless client may make several authentication requests within a few seconds.

      Ideally the cache timeouts would be different. For example i might want to sent the Authentication cache to 30 seconds, but the Authorization cache to longer.

      (From previous email to Les)

      I created a Realm that authenticates against a URL, if the user has
      access. The problem is that we have a stateless client [maven2] that
      connects to our server[Nexus], and needs to authenticate each time.
      This means the same user needs to authenticate 9+ times in a few
      seconds (for a single task).

        Activity

        Les Hazlewood added a comment -

        I implemented this feature to trunk over the weekend - 100% test coverage for methods and lines in AuthenticatingRealm and its parent class. Please try it out!


          People

          • Assignee:
            Les Hazlewood
            Reporter:
            Toby Stevens
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development