Shiro
  1. Shiro
  2. SHIRO-214

Fix OSGI Exports and Imports for org.apache.shiro.ehcache

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: Caching
    • Labels:
      None

      Description

      Shiro Eh-cache has no exports in the Manifest.MF

      Also, it requires a version of 1.4.0 to 2.0.0 for net.sf.ehcache, but upon reviewing the requirements, it requires version 2.2.0 of the Jar.

      I would suggest changing the Import-Package and Export-Package declarations to:

      Import-Package: net.sf.ehcache;version="[1.4.0,3.0.0)",org.apache.shir
      o.cache;version="[1.1.0,2.0.0)",org.apache.shiro.config;version="[1.1
      .0,2.0.0)",org.apache.shiro.io;version="[1.1.0,2.0.0)",org.apache.shi
      ro.util;version="[1.1.0,2.0.0)",org.slf4j;version="1.6"
      Export-Package: org.apache.shiro.cache.ehcache

        Issue Links

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Jason M Jones
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development