Shiro
  1. Shiro
  2. SHIRO-214

Fix OSGI Exports and Imports for org.apache.shiro.ehcache

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: Caching
    • Labels:
      None

      Description

      Shiro Eh-cache has no exports in the Manifest.MF

      Also, it requires a version of 1.4.0 to 2.0.0 for net.sf.ehcache, but upon reviewing the requirements, it requires version 2.2.0 of the Jar.

      I would suggest changing the Import-Package and Export-Package declarations to:

      Import-Package: net.sf.ehcache;version="[1.4.0,3.0.0)",org.apache.shir
      o.cache;version="[1.1.0,2.0.0)",org.apache.shiro.config;version="[1.1
      .0,2.0.0)",org.apache.shiro.io;version="[1.1.0,2.0.0)",org.apache.shi
      ro.util;version="[1.1.0,2.0.0)",org.slf4j;version="1.6"
      Export-Package: org.apache.shiro.cache.ehcache

        Issue Links

          Activity

          Hide
          Alan Cabrera added a comment -

          I was thinking that using PAX Exam to test the headers might be a good idea.

          Show
          Alan Cabrera added a comment - I was thinking that using PAX Exam to test the headers might be a good idea.
          Hide
          Les Hazlewood added a comment -

          This was fixed as a result of finishing SHIRO-274. If you believe this to be incorrect, please reopen the issue.

          Show
          Les Hazlewood added a comment - This was fixed as a result of finishing SHIRO-274 . If you believe this to be incorrect, please reopen the issue.
          Hide
          Les Hazlewood added a comment -

          Closing with the 1.2.0 release.

          Show
          Les Hazlewood added a comment - Closing with the 1.2.0 release.
          Hide
          Tuomas Kiviaho added a comment -

          Please reopen the issue since export clause in pom.xml is not correct.

          Show
          Tuomas Kiviaho added a comment - Please reopen the issue since export clause in pom.xml is not correct.
          Hide
          Les Hazlewood added a comment -

          What does it need to be changed to?

          Show
          Les Hazlewood added a comment - What does it need to be changed to?
          Hide
          Tuomas Kiviaho added a comment -

          It should start as org.apache.shiro.cache.ehcache* where EHCacheManager resides and not as org.apache.shiro.ehcache* which doesn't even exist.

          As a side note: There doesn't seem to be 1.2.1-SNAPSHOT available in the https://repository.apache.org/ although 1.3.0-SNAPSHOT exists.

          Show
          Tuomas Kiviaho added a comment - It should start as org.apache.shiro.cache.ehcache* where EHCacheManager resides and not as org.apache.shiro.ehcache* which doesn't even exist. As a side note: There doesn't seem to be 1.2.1-SNAPSHOT available in the https://repository.apache.org/ although 1.3.0-SNAPSHOT exists.

            People

            • Assignee:
              Unassigned
              Reporter:
              Jason M Jones
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development