Shindig
  1. Shindig
  2. SHINDIG-1509

Strange frameset rendered within javascript

    Details

    • Type: Question Question
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Won't Fix
    • Affects Version/s: 2.0.0
    • Fix Version/s: None
    • Component/s: PHP
    • Labels:
      None
    • Environment:
      Windows7, XAMPP 1.7.4 [PHP: 5.3.5]

      Description

      Hello,

      I have shindig running as a virtual host. Name 'shindig' mapped to 127.0.0.1 in the hosts file.
      When I use "http://shindig/gadgets/ifr?url=http://www.labpixies.com/campaigns/todo/todo.xml" I found the following strange frameset inbetween the rendered javascript part:
      ...
      function _IG_AddDOMEventHandler(src, etype, func)

      { gadgets.warn("_IG_AddDOMEventHandler not implemented - see SHINDIG-198"); }

      <frameset rows="100%,*" frameborder="no" border="0" framespacing="0">
      <frame src="http://www.shindig.com/?fp=F4DZth3CTXk6TL3aXOVfx6KeDDx4%2BfpwCUHi2kxCwyD3PM7GZJL1s6yW19fj5znr%2BH7Qdw6vNxpIp4iwiKynDA%3D%3D&prvtof=aiVUCn7CCaCNLPMu7TGydJ9WL8sIBwiLOLpO4AcsNaRdqLnhP4AmrBkRW7rxeADeKLFsAxEPU06jwlvypVSitB7nFluoWrO4kGjGV2jjpN3Vgp6Rpl3n8GQr9lnL%2B12x&poru=I2tOFFTNOpyvdk81PAJ3YH0qIt2qcBiFwmmhgyqTA%2BVW6Z592rsWQJSfp1k4PJ2r1Ay9nkEiFK4IwW%2F9s2Ag5ptUNXC8xf9bicjyU8F7WqMsNEPXF5m5hjjuY4TgAwHk&">
      </frameset>
      <noframes>
      <body bgcolor="#ffffff" text="#000000">
      <a href="http://www.shindig.com/?fp=F4DZth3CTXk6TL3aXOVfx6KeDDx4%2BfpwCUHi2kxCwyD3PM7GZJL1s6yW19fj5znr%2BH7Qdw6vNxpIp4iwiKynDA%3D%3D&prvtof=e3T%2B8TBsHWD9s96kniyFJnQdeu%2FjQ9SuHmTcvEh3pIdxBa3a3v%2FaONhEj5gc%2Fm9A3POXosYkitE0545be9OGf1rGXlo38ezJ6kSXa2oZrsO8VuWaiUmvRa2MfNX57Dd6&poru=Kdz9XHLXCGdYRV63tzLDiFHdZK91FMIAk6BDg55lsdrV36KzI5sN0rJWlrrEFM2640s0fZXb2a1EHceooizICzqFFJJoWuIdAera9b%2BwTtoi%2F0uwfFIRbuhfV0dJloRk&">Click here to proceed</a>.
      </body>
      </noframes>
      /*

      • Licensed to the Apache Software ...

      As this is no javascript it causes a syntax error and makes the whole gadget unusable showing javscript errors. I was unable to find where that html snippet is coming from. However it is inserted in between the js from legacy.js and dynamic-height-util.js. As a bad work around I openend a comment /* at the end o f legacy.js and closed it in in the beginning of dynamic-height-util.js. With that hack the gadget above is working. But that is of course not a solution. With other gadgets e.g. SocialHelloWorld (http://shindig/gadgets/ifr?url=http://shindig/samplecontainer/examples/SocialHelloWorld.xml) it seems to insert the same frameset, but this time it produces "Error parsing gadget xml:...".

      I tried to check container.php if there is anything looking like a bad reference, but nothing seems to show an indication where that strange frameset is coming from.

      It would be nice if anyone could help me understand what is wrong here.

      Kind regards,
      Thorsten

      1. container.php
        12 kB
        Thorsten Erlewein
      2. RenderedSocialHelloWorld.htm
        34 kB
        Thorsten Erlewein
      3. RenderedTodoExample.htm
        571 kB
        Thorsten Erlewein

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Thorsten Erlewein
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development