Shindig
  1. Shindig
  2. SHINDIG-1492

View level support for Features and Locales

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.0-beta1
    • Fix Version/s: 2.5.0-beta1
    • Component/s: Java
    • Labels:
      None

      Description

      Patch to support View level features and locales which is an approved proposal for OpenSocial 2.0.

      http://docs.opensocial.org/display/OSD/View+Level+Features+Proposal

      Patch includes updated JUnit tests and new EndToEnd test.

      http://codereview.appspot.com/4077043/

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        67d 13h 31m 1 Paul Lindner 03/Apr/11 10:30
        Resolved Resolved Closed Closed
        361d 11h 27m 1 Paul Lindner 29/Mar/12 21:58
        Paul Lindner made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Paul Lindner added a comment -

        part of 2.5.0-beta1 release.

        Gavin made changes -
        Workflow jira [ 12543622 ] patch-available, re-open possible [ 12629984 ]
        Paul Lindner made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Paul Lindner added a comment -

        patch applied. Thanks!

        Matthew Marum made changes -
        Attachment viewlevelFeaturesShindig.patch [ 12475276 ]
        Matthew Marum made changes -
        Attachment issue4077043_90002.diff [ 12475218 ]
        Matthew Marum added a comment -

        I've made some changes, tests now pass on IBM and Sun 1.6 JREs.

        Paul Lindner added a comment -

        still failing for me on mac and linux, jdk 1.6 I think you just need to adjust your mocks for some other code that changed underneath you..

        Matthew Marum made changes -
        Attachment issue4077043_90002.diff [ 12475218 ]
        Matthew Marum added a comment -
        Matthew Marum made changes -
        Attachment viewLevelFeaturesShindig.patch [ 12469326 ]
        Matthew Marum added a comment -

        Unfortunately no, all the test pass in my environment. Those "getFeatureResources" calls are setup in the expectFeatureCalls method of that test.

        Are you taking the latest patch set from the code review tool or the one from here? The one attached here is old. I'll update it just in case.

        Paul Lindner added a comment -

        Any ideas about these test failures when I apply this patch?

        Tests in error:
        unsupportedFeatureThrows(org.apache.shindig.gadgets.render.RenderingGadgetRewriterTest): Unexpected exception, expected<org.apache.shindig.gadgets.rewrite.RewritingException> but was<java.lang.AssertionError>
        unsupportedViewFeatureThrows(org.apache.shindig.gadgets.render.RenderingGadgetRewriterTest): Unexpected exception, expected<org.apache.shindig.gadgets.rewrite.RewritingException> but was<java.lang.AssertionError>


        Caused by: java.lang.AssertionError:
        Unexpected method call getFeatureResources(org.apache.shindig.gadgets.render.RenderingGadgetRewriterTest$MapGadgetContext@4ded4d06, [core, foo], []):
        getFeatureResources(same(org.apache.shindig.gadgets.render.RenderingGadgetRewriterTest$MapGadgetContext@4ded4d06), [foo, core], []): expected: 1, actual: 0
        at org.easymock.internal.MockInvocationHandler.invoke(MockInvocationHandler.java:45)
        at org.easymock.internal.ObjectMethodsFilter.invoke(ObjectMethodsFilter.java:73)
        at org.easymock.internal.ClassProxyFactory$MockMethodInterceptor.intercept(ClassProxyFactory

        Caused by: java.lang.AssertionError:
        Unexpected method call getFeatureResources(org.apache.shindig.gadgets.render.RenderingGadgetRewriterTest$MapGadgetContext@770fba26, [core, foo], []):
        getFeatureResources(same(org.apache.shindig.gadgets.render.RenderingGadgetRewriterTest$MapGadgetContext@770fba26), [foo, core], []): expected: 1, actual: 0
        at org.easymock.internal.MockInvocationHandler.invoke(MockInvocationHandler.java:45)
        at org.easymock.internal.ObjectMethodsFilter.invoke(ObjectMethodsFilter.java:73)
        at org.easymock.internal.ClassProxyFactory$MockMethodInterceptor.intercept(ClassProxyFactory.java:92)
        at org.apache.shindig.gadgets.features.FeatureRegistry$$EnhancerByCGLIB$$f7357840.getFeatureResources(<generated>)

        Matthew Marum made changes -
        Description Patch to support View level features and locales which is an approved proposal for OpenSocial 2.0.

        http://docs.opensocial.org/display/OSD/View+Level+Features+Proposal

        Patch includes updated JUnit tests and new EndToEnd test.
        Patch to support View level features and locales which is an approved proposal for OpenSocial 2.0.

        http://docs.opensocial.org/display/OSD/View+Level+Features+Proposal

        Patch includes updated JUnit tests and new EndToEnd test.

        http://codereview.appspot.com/4077043/
        Matthew Marum made changes -
        Component/s Java [ 12312210 ]
        Matthew Marum added a comment -

        Patch code review on appspot.

        http://codereview.appspot.com/4077043/

        Matthew Marum made changes -
        Attachment viewLevelFeaturesShindig.patch [ 12469324 ]
        Matthew Marum made changes -
        Attachment viewLevelFeaturesShindig.patch [ 12469326 ]
        Matthew Marum added a comment -

        Updated patch to fix some code formatting.

        Matthew Marum made changes -
        Field Original Value New Value
        Attachment viewLevelFeaturesShindig.patch [ 12469324 ]
        Matthew Marum added a comment -

        Patch for View level features/locales

        Matthew Marum created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Matthew Marum
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development