Uploaded image for project: 'Sentry'
  1. Sentry
  2. SENTRY-314

Metastore plugin should verify the storage descriptor before referencing

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.4.0
    • Component/s: None
    • Labels:
      None

      Description

      Some of the metastore operations, like create table and add partition requires validating the URI privilege. We need to check that the storaged descriptor for given table or partition is non null before referencing it. Without that, hive operations like INSERT OVERWRITE TABLE .. PARTITION . statement fails.

        Attachments

        1. SENTRY-314.3.patch
          10 kB
          Prasad Suresh Mujumdar

          Issue Links

            Activity

              People

              • Assignee:
                prasadm Prasad Suresh Mujumdar
                Reporter:
                prasadm Prasad Suresh Mujumdar
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: