Uploaded image for project: 'Sentry'
  1. Sentry
  2. SENTRY-301

Sentry plugin fails access service from secure Hive Metastore

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.4.0
    • Component/s: None
    • Labels:
      None

      Description

      As part of SENTRY-289 patch, the sentry service wraps the transport open under the context of current user. In case of Hive metastore, the current user is impersonate end user. This user context doesn't have kerberor ticket.
      For sentry service, we need to connect as user hive (principal of the metastore service).

        Attachments

        1. SENTRY-301.1.patch
          0.8 kB
          Prasad Suresh Mujumdar

          Activity

            People

            • Assignee:
              prasadm Prasad Suresh Mujumdar
              Reporter:
              prasadm Prasad Suresh Mujumdar
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: