Affects Version/s: None
Fix Version/s: 2.0.0
The SentryPolicyServiceClient + SentryGenericServiceClient have a large number of shared methods, and a small number of methods with the same meaning but with slightly different names. This task is to align both clients so that the shared methods are called the same - this makes it a bit easier to read code when switching from generic to hive etc.
The proposed changes are:
addRoleToGroups -> grantRoleToGroups
deleteRoleToGroups -> revokeRoleFromGroups
listPrivilegesByRoleName -> listAllPrivilegesByRoleName
listRoles -> listAllRoles