Commons SCXML
  1. Commons SCXML
  2. SCXML-82

transition-element as an child of parallel-element ignored

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.8
    • Fix Version/s: 0.9
    • Labels:
      None

      Description

      Hi Rahul,

      sorry - it's me again ...

      The current SCXML draft http://www.w3.org/TR/scxml/#parallel
      allows me to use transitions as an child of parallel-element.

      If I try this, the SCXML implemention ignores this transition.

      Maybe also a little bug ?

      Please refer to the patch attached to this bug (-:

      Regards
      Danny

            • Start engagingTest()
              go now
              WARN - Ignoring element <transition> in namespace "http://www.w3.org/2005/07/scxml" at null:6:52 and digester match "scxml/parallel/transition"
              INFO - /running
              INFO - /running/state1
              INFO - /running/state2
              PASSED: engagingTest

      Rahul said:
      > Yes, in as much as not being implemented is a bug This is another
      > addition in the latest Working Draft which we haven't gotten to yet.
      >
      > Can you open an improvement in JIRA? Please attach the smallest test
      > case (test SCXML documents are good, but if you can attach a complete
      > JUnit test case that'd be even better – see the src/test tree for
      > existing tests for the codebase, you could name this one
      > transitions-05.xml and place it here [1], for example).

        Activity

        Rahul Akolkar made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Rahul Akolkar added a comment -

        Closing since 0.9 is released.

        Rahul Akolkar made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Rahul Akolkar added a comment -

        Thanks for the test, this has been fixed in trunk and a couple of test cases added.

        Rahul Akolkar made changes -
        Summary  transaction-element as an child of parallel-element ignored transition-element as an child of parallel-element ignored
        Rahul Akolkar added a comment -

        This has been fixed in the J6 branch (earlier), and needs to be backported to trunk, which I'll do next week.

        Also updating typo in subject.

        Rahul Akolkar made changes -
        Fix Version/s 0.9 [ 12313270 ]
        Rahul Akolkar added a comment -

        Setting fix version to next release (v0.9).

        Daniel Schwager made changes -
        Field Original Value New Value
        Attachment patch-transition05.diff [ 12387262 ]
        Daniel Schwager added a comment -

        changing testsuite for reproducing this bug

        Daniel Schwager created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Daniel Schwager
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development