Maven SCM
  1. Maven SCM
  2. SCM-291

Errors during date parsing with cvs version 1.12.12.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-beta-4
    • Fix Version/s: 1.0-rc1
    • Component/s: maven-scm-provider-cvs
    • Labels:
      None
    • Environment:
      Linux Suse 10
      CVS 1.12.12

      Description

      The changelog plugin used with cvs client 1.12.12, failed with the following error :
      >> [ERROR] cvs [log aborted]: Can't parse date/time: `2007-02-20T12:15:51+0100'

      The problem comes from the cvs client version 1.12.12 that doesn't seem any more to support the specified time format (yyyy-MM-dd'T'HH:mm:ssZ).

      Tests made with changelog and cvs client version 1.11.6 are ok. Older versions of changelog, prior to issue SCM-177, and cvs client version 1.12.12 work also correctly.

      The problem is solved by replacing the format "yyyy-MM-dd'T'HH:mm:ssZ" by this one "yyyy-MM-dd HH:mm:ssZ" in class AbstractCvsChangeLogCommand.

        Issue Links

          Activity

          johann angeli created issue -
          Emmanuel Venisse added a comment -

          cvs 1.12.* isn't yet a stable release but a "feature" release and it isn't supported yet by Maven-SCM.
          The date format is totally different in cvs 1.12 and we need to allow new formats.

          I can't change the actual format by "yyyy-MM-dd HH:mm:ssZ" for all cvs client because lot of them doesn't support this format. I think I'll allow to change the format in cvs-settings.xml

          Emmanuel Venisse made changes -
          Field Original Value New Value
          Fix Version/s 1.0 [ 13066 ]
          Assignee Emmanuel Venisse [ evenisse ]
          Emmanuel Venisse made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]
          Emmanuel Venisse added a comment -

          yyyy-MM-dd HH:mm:ssZ format is used by default now as it work in cvs 1.11 too
          If a cvs can't use this format, he'll can define an other one in cvs-settings.xml

          Dennis Lundberg made changes -
          Link This issue is depended upon by MCHANGELOG-56 [ MCHANGELOG-56 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 12:22:36 UTC 2015 [ 1428236556206 ]
          Mark Thomas made changes -
          Workflow jira [ 12725303 ] Default workflow, editable Closed status [ 12758023 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 01:08:37 UTC 2015 [ 1428282517778 ]
          Mark Thomas made changes -
          Workflow jira [ 12963201 ] Default workflow, editable Closed status [ 13000320 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          5h 24m 1 Emmanuel Venisse 22/Mar/07 12:17

            People

            • Assignee:
              Emmanuel Venisse
              Reporter:
              johann angeli
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development