Uploaded image for project: 'Samza'
  1. Samza
  2. SAMZA-885

add a dependency to hello-samza project in order to work with the upgraded jackson 1.9.13 library

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: hello-samza
    • Labels:

      Description

      When upgrading to jackson 1.9.13 version in order to be compatible with ne Yarn versions, a new dependency should be added to its pom.xml file.
      <dependency>
      <groupId>org.codehaus.jackson</groupId>
      <artifactId>jackson-mapper-asl</artifactId>
      <version>1.9.13</version>
      </dependency>

      Without this additional dependency Job fails to run with jackson 1.9.13 lib on samza 0.10.1

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              NGalstyan4 Narek
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1h
                1h
                Remaining:
                Remaining Estimate - 1h
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified