Uploaded image for project: 'Samza'
  1. Samza
  2. SAMZA-769

Replace deprecated method call and fix warnings

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.10.0
    • Component/s: None
    • Labels:
      None

      Description

      When running ./gradlew clean build there are some warnings for using deprecated API and missing description for function parameters.
      Example:

      YarnUtil.java uses or overrides a deprecated API
      
      /home/aleksandar/samza_develop/samza/samza-api/src/main/java/org/apache/samza/system/SystemAdmin.java:87: warning: no description for @param
         * @param offset1
           ^
      
      Note: /home/aleksandar/samza_develop/samza/samza-core/src/test/java/org/apache/samza/coordinator/stream/TestCoordinatorStreamWriter.java uses unchecked or unsafe operations.
      
      

      It would be good to fix it.

        Attachments

        1. SAMZA-769.0.patch
          7 kB
          Aleksandar Bircakovic
        2. SAMZA-769.1.patch
          7 kB
          Aleksandar Bircakovic
        3. SAMZA-769-2.patch
          9 kB
          Navina Ramesh

          Activity

            People

            • Assignee:
              a.bircakovic Aleksandar Bircakovic
              Reporter:
              a.bircakovic Aleksandar Bircakovic
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: