Uploaded image for project: 'Samza'
  1. Samza
  2. SAMZA-602

Master fails to compile after SAMZA-600

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.9.0
    • Component/s: kafka, test
    • Labels:
      None

      Description

      I am unable to compile Samza's master branch after the SAMZA-600 commit (I think). I get this error when I run bin/check-all.sh:

      [ant:scalac] Element '/Users/criccomi/Code/samza/samza-kafka/build/resources/main' does not exist.
      /Users/criccomi/Code/samza/samza-kafka/src/test/scala/org/apache/samza/system/kafka/TestKafkaSystemProducer.scala:51: error: not found: type MockKafkaProducer
          val mockProducer = new MockKafkaProducer(1, "test", 1)
                                 ^
      /Users/criccomi/Code/samza/samza-kafka/src/test/scala/org/apache/samza/system/kafka/TestKafkaSystemProducer.scala:68: error: not found: type MockKafkaProducer
          val mockProducer = new MockKafkaProducer(1, "test", 1)
                                 ^
      /Users/criccomi/Code/samza/samza-kafka/src/test/scala/org/apache/samza/system/kafka/TestKafkaSystemProducer.scala:94: error: not found: type MockKafkaProducer
          val mockProducer = new MockKafkaProducer(1, "test", 1)
                                 ^
      /Users/criccomi/Code/samza/samza-kafka/src/test/scala/org/apache/samza/system/kafka/TestKafkaSystemProducer.scala:119: error: not found: type MockKafkaProducer
          val mockProducer = new MockKafkaProducer(1, "test", 1)
                                 ^
      /Users/criccomi/Code/samza/samza-kafka/src/test/scala/org/apache/samza/system/kafka/TestKafkaSystemProducer.scala:150: error: not found: type MockKafkaProducer
          val mockProducer = new MockKafkaProducer(1, "test", 1)
                                 ^
      5 errors found
      

      I think the issue is caused by this Gradle behavior.

      1. SAMZA-602-0.patch
        0.5 kB
        Chris Riccomini

        Activity

        criccomini Chris Riccomini added a comment -

        Attaching patch based off of Gradle forum post fix. No RB since it's a 2-liner.

        closeuris Yan Fang added a comment -

        +1

        criccomini Chris Riccomini added a comment -

        Thanks, Yan! Merged and committed.


          People

          • Assignee:
            criccomini Chris Riccomini
            Reporter:
            criccomini Chris Riccomini
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development