Before we decided on the naming scheme for Samza, some chunks of code refer to containers as "tasks". This is mostly in the Samza YARN AM code, and its accompanying environment variables.
We should go through, and properly update things:
- Rename TASK_ID to CONTAINER_ID in environment variables
- Update YarnConfig to have getContainerCount, not getTaskCount.
- Update YARN AM UI to have Container ID, not Task ID.