Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.6.0
    • Fix Version/s: 0.7.0
    • Component/s: test
    • Labels:
      None

      Description

      We should try running Samza with Java 7.

      Linking to a ticket that shows a build issue in with Samza on Java 7.

      1. SAMZA-16.patch
        7 kB
        Martin Kleppmann

        Issue Links

          Activity

          criccomini Chris Riccomini added a comment -

          Apparently running Samza's tests with Java 7 fails. See SAMZA-10 for details.

          garryturk Garry Turkington added a comment -

          What we seem to be seeing on builds with Java 7 is the following error:

          org.apache.samza.system.kafka.TestTopicMetadataCache > testBasicMetadataCacheFunctionality FAILED
          java.lang.AssertionError at TestTopicMetadataCache.scala:70

          This is an intermittent failure which perhaps suggests a race condition. I've seen it when building on each of the supported versions of Scala.

          martinkl Martin Kleppmann added a comment -

          Ok, I've reproduced that test failure, and I think I've fixed it. Patch attached, rb: https://reviews.apache.org/r/18915/

          The failure was due to state leakage between the two tests in the TestTopicMetadataCache class. They would pass if executed in the order they appear in the file, and fail if executed in the reverse order. Java 7 must have changed something about the order of methods returned by reflection APIs. I've fixed the tests to not leak state, so they should execute fine in any order.

          I've also replaced the use of "assert" with "assertEquals", in order to get better error messages on test failure.

          criccomini Chris Riccomini added a comment -

          +1 Merged and committed.

          martinkl Martin Kleppmann added a comment -

          There are no known issues remaining with Samza on Java 7, so I'm closing this. Please open new issues if you find any problems.


            People

            • Assignee:
              martinkl Martin Kleppmann
              Reporter:
              criccomini Chris Riccomini
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development