Uploaded image for project: 'Samza'
  1. Samza
  2. SAMZA-1436

Upgrade RocksDB to a version w/ Apache license

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.13.1
    • Fix Version/s: 0.14.0
    • Component/s: None
    • Labels:

      Description

      The current version of RocksDB we use does not have Apache license statement yet. For the next release, we will have to upgrade RocksDB version to a later one that complies with Apache2 license.

      According to LEGAL-303, we need to be on RocksDB 5.5.4+. The latest version is RocksDB 5.8. We should try to upgrade to the latest.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              nickpan47 Yi Pan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: