Uploaded image for project: 'Samza'
  1. Samza
  2. SAMZA-1037

CDH 5.4.0 support broken on Samza 0.11

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 0.11.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      We did not achieved to make Samza 0.11 (as 0.10 and master) run with CDH 5.4.0, even following procedure described here in the documentation.

      Build goes fine but everything crash due to some dependency collision at runtime: we spotted at least org.codehaus.jackson and org.apache.zookeeper, but there's probably more.

      We tried from surgical maven exclusions to dependency shading (recreating a CDH 5.4.0 artifact) with no success. We eventually would succeed with the latter but some other dependencies (among which apache commons) collided with our jobs specific ones.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ncolomer Nicolas Colomer
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: