Apache S4
  1. Apache S4
  2. S4-68

PE Prototypes are created from a Thread with the wrong ClassLoader

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.5.0
    • Fix Version/s: 0.6
    • Labels:
      None

      Description

      PE Prototypes are created from a Thread with the wrong ClassLoader. They are created during the App initialization, which is called by the Deployment Manager from a ZK callback.

      We should rework how the Application initialization is done, possibly submitting the initialization task to a separate ExecutionService from the ZK callback, and then setting the right ClassLoader as the Thread contextClassLoader.

        Activity

        Daniel Gómez Ferro added a comment -

        Thanks for reviewing Matthieu!

        Merged in dev commit 0f037e5b3173d4cc298e8c90cbf9b0043f284d58

        Matthieu Morel added a comment -

        +1 test is adequate and runs well. Please merge!

        Daniel Gómez Ferro added a comment -

        Added test in branch S4-68 commit 1c6c6bc60687f9e026491ab020775b754c9bd665

        Matthieu Morel added a comment -

        Thanks for checking. Indeed it would be good to have a test, in order to avoid any later regression. I suppose you have something in mind, since you can tell whether the issue is still there

        Daniel Gómez Ferro added a comment -

        Actually it was still wrong, at least in dev branch

        I submitted a small patch in branch S4-68 commit f86f31b4e5f430131785e844fc13fcbf878333a9

        Should we have a test for this?

        Matthieu Morel added a comment -

        I believe this is fixed with the recent S4-59 updates. Daniel can you confirm?

        Matthieu Morel added a comment -

        Leaving for 0.6

        Matthieu Morel added a comment -

        As a result, setting the context classloader in streams as resolved in S4-61 will probably not be needed anymore.


          People

          • Assignee:
            Daniel Gómez Ferro
            Reporter:
            Daniel Gómez Ferro
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development