Apache S4
  1. Apache S4
  2. S4-64

S4-piper cannot be built on RHEL 5 Linux

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.5.0
    • Fix Version/s: 0.6
    • Labels:
      None
    • Environment:

      Red Hat Enterprise Linux 5
      Java 1.6

      Description

      After cleaning all possible conflicting directories ~/.m2 and ~/.gradle.
      ./gradlew install fails on s4-edsl by throwing a NullPointer() exception.
      The debug code for Gradle shows:

      • Where:
        Build file '/home/user/piper/subprojects/s4-edsl/s4-edsl.gradle' line: 45
      • What went wrong:
        Execution failed for task ':s4-edsl:generateSources'.
        > java.lang.NullPointerException (no error message)

      And line 45 is:
      mojo.execute();

      This applies only to this linux box, since I was able to successfully build piper on a Mac with no problems.

        Activity

        Matthieu Morel added a comment -

        Mariano, which is the exact version number of RHEL that you are using?

        Mariano Valles added a comment -

        It's RHEL release 5.4 (Tikanga) with kernel 2.6.18-164 el5 and on an x86_64 arch.

        Matthieu Morel added a comment -

        Can't reproduce on (some) other linux systems.
        Postponing to 0.6 for further investigation.


          People

          • Assignee:
            Unassigned
            Reporter:
            Mariano Valles
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development