Apache S4
  1. Apache S4
  2. S4-61

Threads running the PEs don't have a Context Class Loader

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.5.0
    • Fix Version/s: 0.5.0
    • Labels:
      None

      Description

      HBase/Hadoop tries to load some classes through the current thread's context class loader. This is not set to the S4RLoader, so it defaults to the thread parent's classLoader, which can't find the required classes.

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Matthieu Morel
            Reporter:
            Daniel Gómez Ferro
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development