Apache S4
  1. Apache S4
  2. S4-55

s4-piper can‘t be executed success on cygwin

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Later
    • Affects Version/s: 0.5.0
    • Fix Version/s: 0.6
    • Labels:
      None
    • Environment:

      cygwin on win7,32bit

      Description

      there is something wrong with script incubator-s4\subprojects\s4-tools\build\install\s4-tools\bin\s4-tools run on cygwin,I have modify the script :
      1.at line 68 script must be "CLASSPATH=$APP_HOME/lib" not "CLASSPATH=$APP_HOME/lib/lib"
      2.after line 161,I add script
      if $cygwin; then
      TMP=''
      for jar in `ls $CLASSPATH/*.jar`
      do
      TMP="$TMP;$jar"
      done
      CLASSPATH=$TMP
      fi
      for parsing CLASSPATH

        Activity

        Hide
        Matthieu Morel added a comment -

        For 0.5, we should focus on running on mac/linux systems that developers can easily test with. It's probably too early too expect full integration with all kinds of environments, and gradle seems to be having issues with cygwin.

        So I'd postpone this to a later release.

        Show
        Matthieu Morel added a comment - For 0.5, we should focus on running on mac/linux systems that developers can easily test with. It's probably too early too expect full integration with all kinds of environments, and gradle seems to be having issues with cygwin. So I'd postpone this to a later release.
        Hide
        Matthieu Morel added a comment -

        Building with cygwin is not currently supported

        Show
        Matthieu Morel added a comment - Building with cygwin is not currently supported
        Hide
        Oleg Tikhonov added a comment -

        Version 0.6.0. Cloned repository on Windows 7 x64 & x32. Built using cygwin. If a path contains Linux file.separator it works. Cygwin cannot replace '\' to '/'.
        Seems to be working.

        I'm curious, why this issue is marked as Blocker?

        Can it be close?

        Show
        Oleg Tikhonov added a comment - Version 0.6.0. Cloned repository on Windows 7 x64 & x32. Built using cygwin. If a path contains Linux file.separator it works. Cygwin cannot replace '\' to '/'. Seems to be working. I'm curious, why this issue is marked as Blocker? Can it be close?
        Hide
        Matthieu Morel added a comment -

        I think the reporter marked it as blocker. I don't think it should be considered as a blocker anyway. And I don't think we should really aim at being compatible with cygwin.

        Did you make any changes to make it work? In that case, you could list those here for the record, otherwise I suggest we simply close as "won't fix".

        Show
        Matthieu Morel added a comment - I think the reporter marked it as blocker. I don't think it should be considered as a blocker anyway. And I don't think we should really aim at being compatible with cygwin. Did you make any changes to make it work? In that case, you could list those here for the record, otherwise I suggest we simply close as "won't fix".

          People

          • Assignee:
            Unassigned
            Reporter:
            bohr.qiu
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 0.5h
              0.5h
              Remaining:
              Remaining Estimate - 0.5h
              0.5h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development