Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Environment:

      mac osx 10.6.8
      git version 1.7.9.2

      Description

      The following happen trying to perform a clean checkout:

      git clone http://git-wip-us.apache.org/repos/asf/incubator-s4.git
      Cloning into 'incubator-s4'...
      remote: Counting objects: 9156, done.
      remote: Compressing objects: 100% (3029/3029), done.
      remote: Total 9156 (delta 4696), reused 8496 (delta 4425)
      Receiving objects: 100% (9156/9156), 18.12 MiB | 635 KiB/s, done.
      Resolving deltas: 100% (4696/4696), done.
      warning: remote HEAD refers to nonexistent ref, unable to checkout.

      Following the suggestion of Harsh J, i tried to go into the created incubator-s4 directory (empty) doing:

      git checkout trunk
      error: pathspec 'trunk' did not match any file(s) known to git.

        Issue Links

          Activity

          Matthieu Morel added a comment -

          Apache's git default checkout branch is master. However there is currently no "master" branch in the S4 repository, since in the proposed development workflow, the master branch refers to the previous release (and there is no such release of S4 under the Apache umbrella yet). See https://issues.apache.org/jira/browse/S4-35

          Solution: until there is a release, you should checkout either "dev" or "piper" branches.

          See https://issues.apache.org/jira/browse/S4-39.

          Matthieu Morel added a comment -

          expected behaviour, due to our development workflow and Apache's git defaults

          Valerio Schiavoni added a comment -

          The text in italic at this page http://incubator.apache.org/s4/contrib/ should be definitely more visible then, as the first command-line given will systematically reproduce the problem. Thanks anyway for the heads-up !


            People

            • Assignee:
              Unassigned
              Reporter:
              Valerio Schiavoni
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development