Apache S4
  1. Apache S4
  2. S4-111

Deployment fails getting the .s4r file from the web

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.5.0
    • Fix Version/s: 0.6

      Description

      Using 0.5.0. Trying to deploy an example s4 app in a distributed environment. First I build the s4r file, leave it in a web server accessible from my machines, and execute the following, getting an error:

      ./s4 deploy -s4r=http://<server>/<path>/twitter-adapter.s4r
        -c=cluster2 -appName=twitter-adapter
      
      01:15:52.584 [main] ERROR org.apache.s4.tools.Deploy
        Specified S4R file does not exist in
        /home/jaime/s4/http:/<server>/<path>/twitter-adapter.s4r
      

      Note from Matthieu: Fetching from http works when the s4r file URI is correct in ZooKeeper. Unfortunately that does not seem to work directly when using the Deploy tool

        Activity

        Matthieu Morel added a comment -

        Thanks for reporting that.

        The problem is simply that the execution flow is wrong: when we get the s4r file location, we should simply use that for the app URI and not try to copy the file.

        Matthieu Morel added a comment -

        Fixed the issue and added a test for the deploy tool.

        Patch available in branch S4-111 , commit [95fd5d6]

        diff: https://git-wip-us.apache.org/repos/asf?p=incubator-s4.git;a=commitdiff;h=refs/heads/S4-111

        Daniel Gómez Ferro added a comment -

        Diff looks good, new test passes and I tested it manually too

        +1

        Matthieu Morel added a comment -

        Merged with dev in commit [57a3999]

        Thanks for the review Daniel!


          People

          • Assignee:
            Matthieu Morel
            Reporter:
            Jaime D
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development