Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Tomcat 5.5.12
    • Browser Version:
      Internet Explorer 6.0
    • Database:
      MySQL 4.1.14
    • JDK Version:
      1.5
    • O/S Version:
      Windows XP SP2

      Description

      AbandonedObjectPool is used (org.apache.tomcat.dbcp.dbcp.AbandonedObjectPool@14d5bc9)
      LogAbandoned: false
      RemoveAbandoned: true
      RemoveAbandonedTimeout: 300

      Found in Tomcat's system out log. Roller is the only application running on the system.

        Activity

        Mark Thomas made changes -
        Workflow jira [ 12457843 ] Default workflow, editable Closed status [ 12622418 ]
        Henri Yandell made changes -
        Project Import Fri Mar 27 23:38:16 PDT 2009 [ 1238222296558 ]
        linda skrocki made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        linda skrocki added a comment -

        Closing per Anil's comment.

        Anil Gangolli made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Anil Gangolli added a comment -

        See prior comments. Closing.

        I do recommend sticking with the AbandonedObjectPool in your config. If you want however, you can easily change it.

        Anil Gangolli made changes -
        Assignee David Johnson [ djohnson ] Anil Gangolli [ agangolli ]
        Anil Gangolli added a comment -

        Not a bug.

        This is determined by the site's configuration, not by the app.

        We recommend (via our installation guide) the use of the deprecated AbandonedObjectPool (due to the use of removeAbandoned=true in the DBCP props). This is not a serious issue. The AbandonedObjectPool does work.

        Based on my own experience, it also works around a bug in DBCP that causes lost connections / incorrect pool size accounting with certain drivers on certain database exceptions.

        Site admins can avoid this simply by changing the DBCP configuration properties in the context xml file, setting the removeAbandoned=false or removing the settings for it and the removeAbandonedTimeout altogether.

        Anil Gangolli made changes -
        Field Original Value New Value
        Priority Major [ 3 ] Minor [ 4 ]
        Dennis Kieselhorst created issue -

          People

          • Assignee:
            Anil Gangolli
            Reporter:
            Dennis Kieselhorst
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development