Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.2
    • Fix Version/s: 2.0
    • Labels:
      None
    • Environment:
      MySQL 5.0.13-rc-standard

      Description

      When running the import of the roller schema into MySQL 5.0 one of the tables has a reserved word as a column name the reserved word is "condition"
      mysql> create database roller;
      Query OK, 1 row affected (0.00 sec)

      mysql>use roller
      Database changed
      mysql> \. /home/akruger/createdb.sql
      [...]
      Query OK, 0 rows affected (0.07 sec)

      Query OK, 0 rows affected (0.09 sec)
      Records: 0 Duplicates: 0 Warnings: 0

      ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'condition integer default 0 not null,
      lastsuccess timestamp null
      )' at line 6
      ERROR 1146 (42S02): Table 'investologist_roller.pingtarget' doesn't exist
      Query OK, 0 rows affected (0.07 sec)
      [...]
      Query OK, 0 rows affected (0.07 sec)
      Records: 0 Duplicates: 0 Warnings: 0

      ERROR 1146 (42S02): Table 'investologist_roller.pingtarget' doesn't exist
      Query OK, 0 rows affected (0.07 sec)
      Records: 0 Duplicates: 0 Warnings: 0

      Query OK, 0 rows affected (0.09 sec)
      Records: 0 Duplicates: 0 Warnings: 0

      Query OK, 0 rows affected (0.12 sec)
      Records: 0 Duplicates: 0 Warnings: 0

      Query OK, 0 rows affected (0.08 sec)
      Records: 0 Duplicates: 0 Warnings: 0

      mysql>

        Activity

        Andre Kruger created issue -
        Andre Kruger added a comment -

        Sorry I am reporting a Bug that has already been fixed ... This is a duplicate of ROL-754

        Anil Gangolli made changes -
        Field Original Value New Value
        Assignee David Johnson [ djohnson ] Anil Gangolli [ agangolli ]
        Anil Gangolli added a comment -

        Duplicate of ROL-754. FIxed in 2.0 but not 1.3.

        Anil Gangolli made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Fix Version/s 2.0 [ 10152 ]
        linda skrocki added a comment -

        Closing per above comment.

        linda skrocki made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Henri Yandell made changes -
        Project Import Fri Mar 27 23:38:16 PDT 2009 [ 1238222296558 ]
        Mark Thomas made changes -
        Workflow jira [ 12458226 ] Default workflow, editable Closed status [ 12622554 ]

          People

          • Assignee:
            Anil Gangolli
            Reporter:
            Andre Kruger
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development