Apache Roller
  1. Apache Roller
  2. ROL-453

Currently Roller does not support the Oracle RDBMS

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Oracle 9i
    • Database:
      Oracle 9i
    • JDK Version:
      JDK 1.4
    • O/S Version:
      Windows, Solaris

      Description

      A few minor changes need to be made to roller in order to support Oracle as its datastore.

      The following files need to be updated to support oracle:

      metadata/database/hibernate/hibernate.properties
      src/org/roller/business/hibernate/HibernateRefererManagerImpl.java
      src/org/roller/pojos/CommentData.java
      src/org/roller/pojos/PageData.java
      src/org/roller/pojos/UserData.java
      src/org/roller/pojos/WeblogEntryData.java

      In addition a clob to string mapping class for hibernate is needed:

      src/org/roller/business/hibernate/HibernateOracleClobType.java

        Activity

        Padraic Hannon added a comment -

        Not sure how to add files.

        Ollie Rutherfurd added a comment -

        Are the modified files or a patch for Oracle support available anywhere?

        Padraic Hannon added a comment -

        I can upload the files if there is a way to do that. I cannot see a way of doing it from this interface.

        Ken Blackler added a comment -

        Hi,
        The only way to post the files seems to be to post them each as comments. I am glad to test the patches if you want.

        Ken

        jorge baez added a comment -

        Hello,

        i'm trying to run roller using oracle. Have you posted or uploaded any of this patches somwhere?

        Thanks!

        Padraic Hannon added a comment -

        Not really interested in posting files as comments. There must be a better way. If people want the files I have been emailing them. I've only gotten a few requests so I assume this isn't something most are interested in.

        -paddy

        jorge baez added a comment -

        I really appreciate your help.
        could you please end me those files to test roller on my environment?

        thanks!

        Ollie Rutherfurd added a comment -

        I'd really love a copy of the changes as well, please: orutherfurd (at) alloy (dot) com

        Marcel Sansaricq added a comment -

        I am also interested to get the files that enable Roller support for Oracle 9i. Please email them to me.
        Thanks in advance for your help

        Gregg Obst added a comment -

        I think for those of us in the corporate world that live and breath Oracle, Oracle support in Roller is essential and should be incorporated into the next release. If someone has a patch set that works, please find a way to share that with Dave and the team so Oracle support becomes a reality. I just spent a week trying to get it to work with Oracle for a pilot project and had to fall back to using hsqldb for the demo to management because we are under deadline.

        Roller would be see great success in the corporate world if Oracle was officially supported.

        Padraic Hannon added a comment -

        I agree, but there is no way to attach files to this tool....

        -paddy

        Georg Schmid added a comment -

        Living in a corporate setting, too, I can only second Gregg's post in the strongest possible way.

        Anyhow, thanks a lot for the product!

        Cheers,
        Georg

        Pankaj added a comment -

        I recently got roller working with Oracle9i and jdk1.5.

        David Johnson added a comment -

        Pankaj, please submit a patch to the dev mailing list if you would like this considered for inclusing in Roller.

        Which version of Roller did you get working with Oracle?

        Carsten Saager added a comment -

        Actually Roller works with 1.4/9i, but you need the latest drivers from Oracle (I use the 10g-drivers). Lately the support for accessing CLOBs as String had been added, with this you can start Roller and create the admin-user.

        Anyway there is another Oracle-quirk: Empty strings are handled as NULL, so there is need for a fix in RollerPropertyData.getValue()

        { return this.value==null?"":this.value;}

        Alternativly (and much cleaner) would be a change to RollerPropertiesAction; instead of
        if(updProp.getValue().equals("true") || updProp.getValue().equals("false")) {
        write
        if("true".equals(updProp.getValue()) || "false".equals(updProp.getValue())) {

        Perhaps a no issue: The driver-fix works only for CLOBs <32k.

        Padraic Hannon added a comment -

        With the latest versions of Hibernate and the 10g drivers Carsten is right. Excepting for the above issue and creating a sql script to create the tables Roller and Oracle should work fine.

        Paul Garvey added a comment -

        I added the 10g oracle driver, and I am able to create a new user, I am even able to create a weblog entry but I get the following errrors trying to view my front page:<br>

        15:39:19,953 ERROR [[PageServlet]] Servlet.service() for servlet PageServlet threw exception
        java.lang.NullPointerException
        at org.apache.roller.config.RollerRuntimeConfig.isFrontPageWeblog(RollerRuntimeConfig.java:223)
        at org.apache.roller.config.RollerRuntimeConfig.isSiteWideWeblog(RollerRuntimeConfig.java:236)
        at org.apache.roller.ui.rendering.servlets.PageServlet.processReferrer(PageServlet.java:456)
        at org.apache.roller.ui.rendering.servlets.PageServlet.doGet(PageServlet.java:129)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:697)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)

        I was having similar errors with getting the Jboss portal to work with oracle. I had to convert CLOBs to varchar2 there and I suspect
        I may have to do the same here.

        Rahul Jain added a comment -

        Hi Padraic,

        Would you mind attaching the files with this issue from the left menu for the patch you are talking of to work with oracle? That might be of some help with the below mentioned issue.

        I am using Roller 3.0, Oracle 10g, Jboss. The problem is while loading Roller in JBoss a NumberFormatException occurs which is probably because of reading the database version using getString from a CLOB datatype.

        But even if we ignore this exception, I am not being able to create even the first Global admin user, because the users.registration.enabled field in ROLLER_PROPERTIES has CLOB as value datatype and hibernate is not being able to read the CLOB datatype as String in RollerPropertyData.java. This results in a page displaying User Registration is disabled even with the first Global Admin user.

        Please let me know if you are aware of any work around for the same.

        Padraic Hannon added a comment -

        Here are the files I have. They are for a much older version of Roller and most likely do not work any more. With Hibernate as the base O/R mapping solution there should be no problem with binding strings to clobs.

        Padraic Hannon added a comment -

        The last file attachment was incorrect.

        Roller User added a comment -

        We are using the following softwares and are unable to create a roller entry

        Database Oracle 10g
        JDBC Drivers version 9.0.2.0.0
        Roller Version 3.1
        Jboss 4.0.1sp1

        We are getting the exception as this

        org.hibernate.exception.GenericJDBCException: could not insert: [org.apache.roller.pojos.WeblogEntryData]
        at org.hibernate.exception.SQLStateConverter.handledNonSpecificException(SQLStateConverter.java:91)
        at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:79)
        at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:43)
        at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2078)
        at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2427)
        at org.hibernate.action.EntityInsertAction.execute(EntityInsertAction.java:51)
        at org.hibernate.engine.ActionQueue.execute(ActionQueue.java:243)
        at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:227)
        at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:140)
        at org.hibernate.event.def.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:296)
        at org.hibernate.event.def.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:27)
        at org.hibernate.impl.SessionImpl.flush(SessionImpl.java:1009)
        at org.hibernate.impl.SessionImpl.managedFlush(SessionImpl.java:356)
        at org.hibernate.transaction.JDBCTransaction.commit(JDBCTransaction.java:106)
        at org.apache.roller.business.hibernate.HibernatePersistenceStrategy.flush(HibernatePersistenceStrategy.java:222)
        at org.apache.roller.business.hibernate.HibernateRollerImpl.flush(HibernateRollerImpl.java:109)
        at org.apache.roller.ui.authoring.struts.actions.WeblogEntryFormAction.save(WeblogEntryFormAction.java:321)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.struts.actions.DispatchAction.dispatchMethod(DispatchAction.java:276)
        at org.apache.struts.actions.DispatchAction.execute(DispatchAction.java:196)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:421)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:226)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1164)
        at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:415)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.roller.ui.core.filters.RequestFilter.doFilter(RequestFilter.java:83)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.roller.ui.rendering.filters.RequestMappingFilter.doFilter(RequestMappingFilter.java:140)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.roller.ui.core.filters.InitFilter.doFilter(InitFilter.java:71)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.roller.ui.core.filters.PersistenceSessionFilter.doFilter(PersistenceSessionFilter.java:60)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:264)
        at org.acegisecurity.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:107)
        at org.acegisecurity.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:72)
        at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
        at org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:110)
        at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
        at org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
        at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
        at org.acegisecurity.wrapper.SecurityContextHolderAwareRequestFilter.doFilter(SecurityContextHolderAwareRequestFilter.java:81)
        at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
        at org.acegisecurity.securechannel.ChannelProcessingFilter.doFilter(ChannelProcessingFilter.java:138)
        at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
        at org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:142)
        at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
        at org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:217)
        at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
        at org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:229)
        at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
        at org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:148)
        at org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:98)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.roller.ui.core.filters.SchemeEnforcementFilter.doFilter(SchemeEnforcementFilter.java:121)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.roller.ui.core.filters.StrutsCharEncodingFilter.doFilter(StrutsCharEncodingFilter.java:90)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.roller.ui.core.filters.CharEncodingFilter.doFilter(CharEncodingFilter.java:81)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:81)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
        at org.jboss.web.tomcat.security.CustomPrincipalValve.invoke(CustomPrincipalValve.java:39)
        at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:159)
        at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:59)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
        at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
        at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)
        at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
        at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
        at java.lang.Thread.run(Thread.java:595)
        Caused by: java.sql.SQLException: Data size bigger than max size for this type: 25848
        at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
        at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:179)
        at oracle.jdbc.ttc7.TTCItem.setArrayData(TTCItem.java:147)
        at oracle.jdbc.dbaccess.DBDataSetImpl.setBytesBindItem(DBDataSetImpl.java:2460)
        at oracle.jdbc.driver.OraclePreparedStatement.setItem(OraclePreparedStatement.java:1190)
        at oracle.jdbc.driver.OraclePreparedStatement.setString(OraclePreparedStatement.java:1610)
        at org.jboss.resource.adapter.jdbc.WrappedPreparedStatement.setString(WrappedPreparedStatement.java:288)
        at org.hibernate.type.StringType.set(StringType.java:26)
        at org.hibernate.type.NullableType.nullSafeSet(NullableType.java:85)
        at org.hibernate.type.NullableType.nullSafeSet(NullableType.java:58)
        at org.hibernate.persister.entity.AbstractEntityPersister.dehydrate(AbstractEntityPersister.java:1826)
        at org.hibernate.persister.entity.AbstractEntityPersister.dehydrate(AbstractEntityPersister.java:1803)
        at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2059)
        ... 87 more

        Roller User added a comment -

        Can the above issue be tackled by doing some configuration changes and avoiding roller code changes? Are we using the correct compatible versions of the softwares or we should try some other things. Please suggest.

        Henri Yandell added a comment -

        First step - use the 10g JDBC driver and not the 9i one.

        I don't get that exact exception, but I do get an exception on my first create entry.

        Ceri Davies added a comment -

        This works now, proviso a number of bugs that should be raised as Oracle bugs (and we've logged all of the ones that we've found). I think that this ticket can be closed.

        Glen Mazza added a comment -

        Closing issue per last comment.


          People

          • Assignee:
            Roller Unassigned
            Reporter:
            Padraic Hannon
          • Votes:
            8 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development