Uploaded image for project: 'Apache Roller'
  1. Apache Roller
  2. ROL-2057

Missing NPE check in Roller PageServlet class

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.1.1
    • Fix Version/s: 5.1.2
    • Labels:
      None
    • Environment:
      WildFly8.2.0.Final

      Description

      After I finish procedures of official installation guide for JBoss,
      and I create a new blog, but the blog can't be visible.
      URLs of the top page or the blog are always returning status 500,
      and many NPEs are dumped on logs. like this:

      <snip>
      Caused by: java.lang.NullPointerException
      at io.undertow.servlet.spec.ServletContextImpl.getMimeType(ServletContextImpl.java:192)
      at org.apache.roller.weblogger.ui.rendering.servlets.PageServlet.doGet(PageServlet.java:423)
      <snip>

      It looks like that the cause is came from WildFly implementation of ServletContext.
      (https://github.com/undertow-io/undertow/blob/master/servlet/src/main/java/io/undertow/servlet/spec/ServletContextImpl.java)
      It has no null-check of the argument.

      1. ROL-2057.patch
        2 kB
        Kohei Nozaki

        Activity

        gmazza Glen Mazza added a comment -

        Committed revision 1649453.
        Thanks for the patch.

        djohnson David Johnson added a comment -

        5.1.2 released


          People

          • Assignee:
            roller_unassigned Roller Unassigned
            Reporter:
            xkylex Kohei Nozaki
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development