Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.0
    • Fix Version/s: 5.0
    • Component/s: Media files / uploads
    • Labels:
      None
    • Environment:
      glassfish v3.1, opensolaris, client is "windows live writer 2011",
      blogger / metaweblog API disabled
    • Database:
      mysql 5
    • O/S Version:
      opensolaris

      Description

      attempting to post a simple image in a page using ATOM fails.
      image URL shows up but where is the image? No trace of it.

      Attempting to publish again with the same thing (with metaweblog DISABLED) produces:

      ERROR 2011-03-09 17:28:23,957 XmlRpcErrorLogger:log - Failed to invoke method editPost in class org.
      apache.roller.weblogger.webservices.xmlrpc.MetaWeblogAPIHandler: 0
      org.apache.xmlrpc.common.XmlRpcInvocationException: Failed to invoke method editPost in class org.ap
      ache.roller.weblogger.webservices.xmlrpc.MetaWeblogAPIHandler: 0
      ...
      ... 85 more
      Caused by:
      java.lang.ArrayIndexOutOfBoundsException: 0
      at org.apache.roller.weblogger.webservices.xmlrpc.MetaWeblogAPIHandler.editPost(MetaWeblogAPIHandler.java:144)

        Activity

        David Johnson added a comment -

        Author: snoopdave
        Date: Sun Mar 13 18:21:06 2011
        New Revision: 1081183

        URL: http://svn.apache.org/viewvc?rev=1081183&view=rev
        Log:
        Fix for ROL-1913, cannot disable client APIs at site-wide level

        Modified:
        roller/trunk/weblogger-web/src/main/java/org/apache/roller/weblogger/webservices/atomprotocol/RollerAtomService.java
        roller/trunk/weblogger-web/sr

        Glen Mazza added a comment -

        Closed issues related to Roller 5.0 release.


          People

          • Assignee:
            David Johnson
            Reporter:
            peter evans
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development