Uploaded image for project: 'Apache Roller'
  1. Apache Roller
  2. ROL-1785

Design menu not showing when themes.customtheme.allowed=false

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Later
    • Affects Version/s: 5.0
    • Fix Version/s: None
    • Component/s: Themes and Macros
    • Labels:
      None

      Description

      In editor-menu.xml there is an option set to not show the design menu if themes.customtheme.allowed is set to false.
      ie:
      enabledProperty="themes.customtheme.allowed">

      This will completely disable the theme switching also. There is a action:

      <action name="themeEdit!*" method="

      {1}

      "
      class="org.apache.roller.weblogger.ui.struts2.editor.ThemeEdit">
      <result name="input" type="tiles">.ThemeEdit</result>
      <result name="input-sharedonly" type="tiles">.ThemeEditSharedThemesOnly</result>
      </action>

      that takes care of this and only allows theme switching. I am not sure if this is now what it is supposed to do ie completelt disable themes, we loose functionality if it is.

      Also .ThemeEditSharedThemesOnly is missing from tiles.xml.

      Cheers Greg

        Attachments

          Activity

            People

            • Assignee:
              roller_unassigned Roller Unassigned
              Reporter:
              gregh Greg Huber
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: