Apache Roller
  1. Apache Roller
  2. ROL-1782

Rich Text Editor (Xinha) always set URL to relative path.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.0
    • Labels:
      None
    • Environment:
      I used it under OpenSolaris 2009-11, with Firefox 3.
    • Browser Version:
      Firefox 3
    • Level of effort:
      2h

      Description

      I created this entry via the Rich Text Editor on blogs.sun.com: http://blogs.sun.com/TheGlobosso/entry/opensso_home_page_in_french. I've added there an image that I've uploaded before to my blog (File Upload section).

      The html code generated is <p><img src="/TheGlobosso/resource/French/logo_French_link.png" /> </p> , and it works fine on my blog. The problem is on the OpenSSO Planet associated: the image is not displayed there.

      This is because the image has a relative and not an absolute one. The problem is: even changing manually the html code, I can not have a absolute path for my image.
      when I change the <img src="/TheGlobosso/resource/French/logo_French_link.png" /> to <img src="http://blogs.sun.com/TheGlobosso/resource/French/logo_French_link.png" />, either by editing the html code, or either clicking on the image 'Insert/Modify Image' button, and then save, the code is modified back to the relative path.

      I tried do set my URL to an absolute path via the normal text editor, and it worked: image is now well displayed in both my blog and the planet, and the URL is not rested by default to a relative one.

        Activity

        Pierre-antoine Berreur created issue -
        Ceri Davies added a comment -

        I can't reproduce this with a stock 4.0.1 and Xinha - does blogs.sun.com use something else, or has this been fixed in the meantime?

        Henri Yandell made changes -
        Field Original Value New Value
        Project Import Fri Mar 27 23:38:16 PDT 2009 [ 1238222296558 ]
        David Johnson added a comment -

        Looks like all we need to do is add this to the Xinha config:
        xinha_config.stripBaseHref = false;

        I'll do that in 5.0 and I'll upgrade to the latest Xinha (0.95)

        David Johnson made changes -
        Assignee Roller Unassigned [ roller_unassigned ] David Johnson [ djohnson ]
        Fix Version/s 5.0 [ 12313828 ]
        David Johnson added a comment -
        David Johnson made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Level of effort Will need to use again ScribeFire since this Rich html editor resets local URLs. 2h
        Resolution Fixed [ 1 ]
        Mark Thomas made changes -
        Workflow jira [ 12459267 ] Default workflow, editable Closed status [ 12623364 ]
        Glen Mazza added a comment -

        Closed issues related to Roller 5.0 release.

        Glen Mazza made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            David Johnson
            Reporter:
            Pierre-antoine Berreur
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development