Apache Roller
  1. Apache Roller
  2. ROL-1592

Limited blogger is still able to post a group weblog

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.0
    • Fix Version/s: 5.1
    • Component/s: User Management
    • Labels:
      None
    • Environment:
      Glassfish - WinXP
    • Browser Version:
      I.E 7.x
    • Customer(s):
      Sun/App Platform
    • Database:
      Derby 10.2.2
    • JDK Version:
      1.6.0_02
    • O/S Version:
      Glassfish - WinXP

      Description

      A limited blogger is able to Post a group blog entry without requiring for a review. The Post to Weblog button is not greyed out for limited blogger

      STEPS TO REPRODCUE:
      1. Install S4/Roller - Hudson 10/23/07, 203 window build
      2. Create user1 and user2
      3. Login Roller as user1 > create a Web Log > an entry
      4. Invite User2 to join the User1 blog as limited user
      5. Login as user2 > accept the invitation from User1
      6. Edit user1' blog entry and try to post the change
      BUG:
      User2 is able to update user1's blog entry even he is limited blogger

        Activity

        Glen Mazza added a comment -

        Could not replicate this particular error, but spotted several others that I fixed today. Thanks for bringing to our attention.

        Glen Mazza added a comment -

        Closing is better for a can't reproduce.


          People

          • Assignee:
            Roller Unassigned
            Reporter:
            Davis Nguyen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development