Apache Roller
  1. Apache Roller
  2. ROL-1343

Clicking the Full Preview button should execute "Save as Draft" logic so user doesn't lose their post

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Labels:
      None
    • Browser Version:
      Firefox
    • Customer(s):
      raibledesigns.com
    • Database:
      MySQL 3.23
    • JDK Version:
      1.5
    • O/S Version:
      Linux

      Description

      To reproduce, create a new entry. Save it as a draft. On the resulting screen, add more text to the entry and then click "Full Preview". The preview screen doesn't contain the added text and if the user clicks "Edit" the text is not their either. If they click "back" on their browser, it may be there, but we should do everything we can do preserve edited posts. Losing a post is the worst thing that can happen to a blogger IMO.

        Activity

        David Johnson added a comment -

        In my setup on Firefox, the preview page comes up in a new tab in my browser. The new text that I added is not lost, it's still there in the original tab.

        In Safari and IE7, the preview comes up in a new browser window and again the new text is not lost because it is present in the original window.

        I don't have a problem with that behavior.

        David Johnson added a comment -

        I believe this feature is working as designed in Roller 3.1, so I'm taking this off the fix-for 3.1 list.

        If you want to change this behavior, please propose a solution to roller-dev list.

        Matt Raible added a comment -

        The opening in a new tab/window works fine. However, if you edit an entry (after saving it so you can see the Full Preview button) and then click Full Preview, it won't show the changes you made. It's merely a workflow thing that users will have to learn - you always have to click Save as Draft before Full Preview. It'd be nice if clicking Save as Draft wasn't required to see changes when clicking Full Preview.

        Glen Mazza added a comment -

        Retiring this 2007 issue as nobody seems inclined to change the code over this. As with Dave in 2007, I've never had a problem with the current behavior, and I've blogged with Roller very heavily for years. At worst it's just a easily learned quirk with Roller that you need to first save and validate your text before hitting the Preview button, if you wish for the latter to reproduce the latest text you entered.

        But tying the Save validation into the Preview (as a result of combining the functionality) seems messy and not worth the effort, and has the slight drawback of sending the user's text to the server (as a consequence of the preview now doing a save) before he may have intended for that to happen.


          People

          • Assignee:
            Roller Unassigned
            Reporter:
            Matt Raible
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development