Apache Roller
  1. Apache Roller
  2. ROL-1225

Stale comment authentication values in IE

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 3.0
    • Labels:
      None
    • Environment:
      IE 6 browser with Roller 2.3
    • Browser Version:
      IE 6

      Description

      Users have complained about IE 6 displaying cached/stale numbers in the "math question".
      Max Rudman suggests the following fix.

      — Email excerpt:
      Max Rudman <mrudman@steelbrick.com> wrote:

      I don't know if this is limited to 6 but this definitely seems to be
      IE-specific problem. The issue is that the include generated by
      CommentAuthenticatorServlet is getting cached. So, when you post a
      comment and the page gets redisplayed, IE includes cached HTML
      fragment which has the previous math question. The solution is to
      output cache-defeating headers in CommentAuthenticatiorServlet.doGet
      () method:

      response.addHeader("Pragma", "no-cache");
      response.addHeader("Cache-Control", "no-cache");
      response.addHeader("Expires", "-1");

      Max

      On Aug 30, 2006, at 9:39 AM, Dave Johnson wrote:

      > Is this an IE6 only problem?
      >
      > Do you need the comment authenticator for your blog? If it's an
      > internal portal, then you can probably live without it – and you can
      > turn it off.
      >
      > - Dave

        Activity

        Anil Gangolli created issue -
        Anil Gangolli made changes -
        Field Original Value New Value
        Browser Version IE 6
        Description
        Users have complained about IE 6 displaying cached/stale numbers in the "math question".
        Max Rudman suggests the following fix.


        --- Email excerpt:
        Max Rudman <mrudman@steelbrick.com> wrote:

        I don't know if this is limited to 6 but this definitely seems to be
        IE-specific problem. The issue is that the include generated by
        CommentAuthenticatorServlet is getting cached. So, when you post a
        comment and the page gets redisplayed, IE includes cached HTML
        fragment which has the previous math question. The solution is to
        output cache-defeating headers in CommentAuthenticatiorServlet.doGet
        () method:

        response.addHeader("Pragma", "no-cache");
        response.addHeader("Cache-Control", "no-cache");
        response.addHeader("Expires", "-1");


        Max


        On Aug 30, 2006, at 9:39 AM, Dave Johnson wrote:

        > Is this an IE6 only problem?
        >
        > Do you need the comment authenticator for your blog? If it's an
        > internal portal, then you can probably live without it -- and you can
        > turn it off.
        >
        > - Dave
        Users have complained about IE 6 displaying cached/stale numbers in the "math question".
        Max Rudman suggests the following fix.


        --- Email excerpt:
        Max Rudman <mrudman@steelbrick.com> wrote:

        I don't know if this is limited to 6 but this definitely seems to be
        IE-specific problem. The issue is that the include generated by
        CommentAuthenticatorServlet is getting cached. So, when you post a
        comment and the page gets redisplayed, IE includes cached HTML
        fragment which has the previous math question. The solution is to
        output cache-defeating headers in CommentAuthenticatiorServlet.doGet
        () method:

        response.addHeader("Pragma", "no-cache");
        response.addHeader("Cache-Control", "no-cache");
        response.addHeader("Expires", "-1");


        Max


        On Aug 30, 2006, at 9:39 AM, Dave Johnson wrote:

        > Is this an IE6 only problem?
        >
        > Do you need the comment authenticator for your blog? If it's an
        > internal portal, then you can probably live without it -- and you can
        > turn it off.
        >
        > - Dave
        Anil Gangolli made changes -
        Assignee David Johnson [ djohnson ] Anil Gangolli [ agangolli ]
        Anil Gangolli added a comment -

        Fixed applying essentially the specified patch.

        // Convince proxies and IE not to cache this.
        response.addHeader("Pragma", "no-cache");
        response.addHeader("Cache-Control", "no-cache");
        response.addHeader("Expires", "Thu, 01 Jan 1970 00:00:00 GMT");

        (Note that HTTP 1.1 spec requires the server to use RFC 1123 date format on the Expires header, but also requires clients to interpret any pure numeric or ill-formed dates as already expired.)

        Applied fix in trunk in SVN revision 438817

        Applied fix in Roller 3.0 branch in SVN revision 438819

        Anil Gangolli added a comment -


        Fixed in trunk and 3.0.

        Anil Gangolli made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 3.0 [ 10230 ]
        Fix Version/s 2.4 [ 10221 ]
        Anil Gangolli added a comment -

        A user on the roller-user list suggests the following workaround for Roller 2.3:

        Change: /theme/scripts/clientSideInclude.js Add an ignored time parameter to confound browser-side caching
        "url=url+"?time=" + new Date().getTime();" at the beginning of function clientSideInclude(id,url).

        Henri Yandell made changes -
        Project Import Fri Mar 27 23:38:16 PDT 2009 [ 1238222296558 ]
        Mark Thomas made changes -
        Workflow jira [ 12458726 ] Default workflow, editable Closed status [ 12623569 ]
        Glen Mazza added a comment -

        Closing all resolved/fixed issues of already released versions of Roller.

        Glen Mazza made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1h 38m 1 Anil Gangolli 31/Aug/06 06:47
        Resolved Resolved Closed Closed
        2319d 13h 59m 1 Glen Mazza 05/Jan/13 20:46

          People

          • Assignee:
            Anil Gangolli
            Reporter:
            Anil Gangolli
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development