Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0.0-incubating
    • Component/s: None
    • Labels:
      None

      Description

      Hello~I'm new in this project. Nice to join!
      Though, I got some problem while running in example. I'm following page below.

      https://rocketmq.incubator.apache.org/docs/quick-start/
      I got problem when I ran 'sh bin/tools.sh org.apache.rocketmq.example.quickstart.Producer'
      ```
      kwangin-ui-MacBook-Pro:apache-rocketmq-all kwangin$ sh bin/tools.sh org.apache.rocketmq.example.quickstart.Producer
      Java HotSpot(TM) 64-Bit Server VM warning: ignoring option PermSize=128m; support was removed in 8.0
      Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=128m; support was removed in 8.0
      22:48:30.770 [main] DEBUG i.n.u.i.l.InternalLoggerFactory - Using SLF4J as the default logging framework
      22:48:30.783 [main] DEBUG i.n.c.MultithreadEventLoopGroup - -Dio.netty.eventLoopThreads: 8
      22:48:30.791 [main] DEBUG i.n.util.internal.PlatformDependent0 - java.nio.Buffer.address: available
      22:48:30.791 [main] DEBUG i.n.util.internal.PlatformDependent0 - sun.misc.Unsafe.theUnsafe: available
      22:48:30.792 [main] DEBUG i.n.util.internal.PlatformDependent0 - sun.misc.Unsafe.copyMemory: available
      22:48:30.792 [main] DEBUG i.n.util.internal.PlatformDependent0 - java.nio.Bits.unaligned: true
      22:48:30.793 [main] DEBUG i.n.util.internal.PlatformDependent - Java version: 8
      22:48:30.793 [main] DEBUG i.n.util.internal.PlatformDependent - -Dio.netty.noUnsafe: false
      22:48:30.793 [main] DEBUG i.n.util.internal.PlatformDependent - sun.misc.Unsafe: available
      22:48:30.794 [main] DEBUG i.n.util.internal.PlatformDependent - -Dio.netty.noJavassist: false
      22:48:30.913 [main] DEBUG i.n.util.internal.PlatformDependent - Javassist: available
      22:48:30.913 [main] DEBUG i.n.util.internal.PlatformDependent - -Dio.netty.tmpdir: /var/folders/yb/lbbgbq212y9cbsf0515mkl0r0000gn/T (java.io.tmpdir)
      22:48:30.914 [main] DEBUG i.n.util.internal.PlatformDependent - -Dio.netty.bitMode: 64 (sun.arch.data.model)
      22:48:30.914 [main] DEBUG i.n.util.internal.PlatformDependent - -Dio.netty.noPreferDirect: false
      22:48:30.933 [main] DEBUG io.netty.channel.nio.NioEventLoop - -Dio.netty.noKeySetOptimization: false
      22:48:30.934 [main] DEBUG io.netty.channel.nio.NioEventLoop - -Dio.netty.selectorAutoRebuildThreshold: 512
      22:48:31.017 [main] DEBUG i.n.util.internal.ThreadLocalRandom - -Dio.netty.initialSeedUniquifier: 0x9368bac8ff74c818 (took 13 ms)
      22:48:31.050 [main] DEBUG io.netty.buffer.ByteBufUtil - -Dio.netty.allocator.type: unpooled
      22:48:31.050 [main] DEBUG io.netty.buffer.ByteBufUtil - -Dio.netty.threadLocalDirectBufferSize: 65536
      22:48:31.050 [main] DEBUG io.netty.buffer.ByteBufUtil - -Dio.netty.maxThreadLocalCharBufferSize: 16384
      22:48:31.093 [NettyClientSelector_1] DEBUG i.n.u.i.JavassistTypeParameterMatcherGenerator - Generated: io.netty.util.internal._matchers_.org.apache.rocketmq.remoting.protocol.RemotingCommandMatcher
      org.apache.rocketmq.client.exception.MQClientException: No route info of this topic, TopicTest
      See http://rocketmq.apache.org/docs/faq/ for further details.
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.sendDefaultImpl(DefaultMQProducerImpl.java:559)
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.send(DefaultMQProducerImpl.java:1049)
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.send(DefaultMQProducerImpl.java:1008)
      at org.apache.rocketmq.client.producer.DefaultMQProducer.send(DefaultMQProducer.java:204)
      at org.apache.rocketmq.example.quickstart.Producer.main(Producer.java:63)
      org.apache.rocketmq.client.exception.MQClientException: No route info of this topic, TopicTest
      See http://rocketmq.apache.org/docs/faq/ for further details.
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.sendDefaultImpl(DefaultMQProducerImpl.java:559)
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.send(DefaultMQProducerImpl.java:1049)
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.send(DefaultMQProducerImpl.java:1008)
      at org.apache.rocketmq.client.producer.DefaultMQProducer.send(DefaultMQProducer.java:204)
      at org.apache.rocketmq.example.quickstart.Producer.main(Producer.java:63)
      org.apache.rocketmq.client.exception.MQClientException: No route info of this topic, TopicTest
      See http://rocketmq.apache.org/docs/faq/ for further details.
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.sendDefaultImpl(DefaultMQProducerImpl.java:559)
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.send(DefaultMQProducerImpl.java:1049)
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.send(DefaultMQProducerImpl.java:1008)
      at org.apache.rocketmq.client.producer.DefaultMQProducer.send(DefaultMQProducer.java:204)
      at org.apache.rocketmq.example.quickstart.Producer.main(Producer.java:63)
      org.apache.rocketmq.client.exception.MQClientException: No route info of this topic, TopicTest
      See http://rocketmq.apache.org/docs/faq/ for further details.
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.sendDefaultImpl(DefaultMQProducerImpl.java:559)
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.send(DefaultMQProducerImpl.java:1049)
      at org.apache.rocketmq.client.impl.producer.DefaultMQProducerImpl.send(DefaultMQProducerImpl.java:1008)
      at org.apache.rocketmq.client.producer.DefaultMQProducer.send(DefaultMQProducer.java:204)
      at org.apache.rocketmq.example.quickstart.Producer.main(Producer.java:63)
      ```
      I started name server/broker and exported NAMESRV add.

      Those anyone know about this?

      Thanks.

        Issue Links

          Activity

          djkooks Kwang-in (Dennis) JUNG added a comment -

          Also, I have failure on test with 'mvn clean test'

          ```
          [INFO] Apache RocketMQ 4.0.0-SNAPSHOT ..................... SUCCESS [ 2.824 s]
          [INFO] rocketmq-remoting 4.0.0-SNAPSHOT ................... SUCCESS [ 5.700 s]
          [INFO] rocketmq-common 4.0.0-SNAPSHOT ..................... SUCCESS [ 3.415 s]
          [INFO] rocketmq-client 4.0.0-SNAPSHOT ..................... SUCCESS [ 8.014 s]
          [INFO] rocketmq-store 4.0.0-SNAPSHOT ...................... FAILURE [ 3.881 s]
          [INFO] rocketmq-srvutil 4.0.0-SNAPSHOT .................... SKIPPED
          [INFO] rocketmq-broker 4.0.0-SNAPSHOT ..................... SKIPPED
          [INFO] rocketmq-tools 4.0.0-SNAPSHOT ...................... SKIPPED
          [INFO] rocketmq-namesrv 4.0.0-SNAPSHOT .................... SKIPPED
          [INFO] rocketmq-example 4.0.0-SNAPSHOT .................... SKIPPED
          [INFO] rocketmq-filtersrv 4.0.0-SNAPSHOT .................. SKIPPED
          [INFO] rocketmq-test 4.0.0-SNAPSHOT ....................... SKIPPED
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD FAILURE
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 24.256 s
          [INFO] Finished at: 2017-02-07T23:43:49+09:00
          [INFO] Final Memory: 35M/328M
          [INFO] ------------------------------------------------------------------------
          [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.19.1:test (default-test) on project rocketmq-store: There are test failures.
          [ERROR]
          [ERROR] Please refer to /Users/kwangin/workspace/incubator-rocketmq/store/target/surefire-reports for the individual test results.
          [ERROR] -> [Help 1]
          org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.19.1:test (default-test) on project rocketmq-store: There are test failures.

          Please refer to /Users/kwangin/workspace/incubator-rocketmq/store/target/surefire-reports for the individual test results.
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
          at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
          at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
          at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
          at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
          at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
          at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
          at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
          at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:498)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
          at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
          at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
          Caused by: org.apache.maven.plugin.MojoFailureException: There are test failures.

          Please refer to /Users/kwangin/workspace/incubator-rocketmq/store/target/surefire-reports for the individual test results.
          at org.apache.maven.plugin.surefire.SurefireHelper.reportExecution(SurefireHelper.java:91)
          at org.apache.maven.plugin.surefire.SurefirePlugin.handleSummary(SurefirePlugin.java:320)
          at org.apache.maven.plugin.surefire.AbstractSurefireMojo.executeAfterPreconditionsChecked(AbstractSurefireMojo.java:892)
          at org.apache.maven.plugin.surefire.AbstractSurefireMojo.execute(AbstractSurefireMojo.java:755)
          at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
          ... 20 more
          [ERROR]
          [ERROR] Re-run Maven using the -X switch to enable full debug logging.
          [ERROR]
          [ERROR] For more information about the errors and possible solutions, please read the following articles:
          [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
          [ERROR]
          [ERROR] After correcting the problems, you can resume the build with the command
          [ERROR] mvn <goals> -rf :rocketmq-store
          ```
          Is this related with this?

          Yukon yukon added a comment - - edited

          If there are some compile errors, the compile target may be not complete, could you please provide more details(-X log, env, jdk, etc) about the compile errors?

          vongosling vongosling added a comment -

          Could you paste the detail diagnosis info for building process. IMO, your build failure may be associated with your local environment

          githubbot ASF GitHub Bot added a comment -

          GitHub user dongeforever opened a pull request:

          https://github.com/apache/incubator-rocketmq/pull/54

          ROCKETMQ-83 Fix quick start, annotate setNamesrvAddr

          Fix quick start, annotate setNamesrvAddr

          @zhouxinyu please have a review

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/dongeforever/incubator-rocketmq ROCKETMQ-83

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/incubator-rocketmq/pull/54.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #54


          commit b72024c4a151245b21d11539aea41c52e7397491
          Author: dongeforever <zhendongliu92@yeah.net>
          Date: 2017-02-08T03:01:25Z

          ROCKETMQ-83 Fix quick start, annotate setNamesrvAddr


          githubbot ASF GitHub Bot added a comment -

          Github user zhouxinyu commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          Hi, `quickStart.Consumer` also has the same issue, could you please fix it.

          githubbot ASF GitHub Bot added a comment -

          Github user lizhanhui commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          Yes, both quickstart.Consumer and quickstart.Producer should have xxx.setNamesrv("XXX") as part of documentation, showing how to set name server list programmatically. My fault to leave them as code.

          githubbot ASF GitHub Bot added a comment -

          Github user dongeforever commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          @zhouxinyu Consumer is also ok now

          githubbot ASF GitHub Bot added a comment -

          Github user lizhanhui commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          Could you relocate the line properly and wrap the code using appropriate javadoc, say

          {@code Code is here;}

          http://stackoverflow.com/questions/541920/multiple-line-code-example-in-javadoc-comment

          githubbot ASF GitHub Bot added a comment -

          Github user djKooks commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          It works fine. Thanks!

          githubbot ASF GitHub Bot added a comment -

          Github user vongosling commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          @lizhanhui This problem let me feel a bit awkward when we double-check the 4.0.0 vote checklist. May be, we need to let example module into integration test

          githubbot ASF GitHub Bot added a comment -

          Github user zhouxinyu commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          @vongosling I have created a new JIRA issue for it: https://issues.apache.org/jira/browse/ROCKETMQ-84

          githubbot ASF GitHub Bot added a comment -

          Github user lizhanhui commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          Agree. All directly executable code should be part of the e2e tests.

          githubbot ASF GitHub Bot added a comment -

          Github user lizhanhui commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          BTW, should we remove example.transaction.* as this feature is not fully implemented in current release. It does not make sense having orphan examples alone.

          githubbot ASF GitHub Bot added a comment -

          Github user vongosling commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          Agree

          githubbot ASF GitHub Bot added a comment -

          Github user djKooks commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          How about make a new PR for https://issues.apache.org/jira/browse/ROCKETMQ-84 and update this one? Becuase title is for ROCKETMQ-83, somebody would be confused.

          githubbot ASF GitHub Bot added a comment -

          Github user coveralls commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          [![Coverage Status](https://coveralls.io/builds/10049054/badge)](https://coveralls.io/builds/10049054)

          Coverage increased (+0.3%) to 31.586% when pulling *b271e30a2da3e0972f95d6c3b29e05f89584a71c on dongeforever:ROCKETMQ-83* into *e6aaedcf4d23f95791c51fb510baf369c8b1f5c1 on apache:master*.

          githubbot ASF GitHub Bot added a comment -

          Github user coveralls commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          [![Coverage Status](https://coveralls.io/builds/10049068/badge)](https://coveralls.io/builds/10049068)

          Coverage increased (+0.2%) to 31.488% when pulling *b271e30a2da3e0972f95d6c3b29e05f89584a71c on dongeforever:ROCKETMQ-83* into *e6aaedcf4d23f95791c51fb510baf369c8b1f5c1 on apache:master*.

          githubbot ASF GitHub Bot added a comment -

          Github user coveralls commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          [![Coverage Status](https://coveralls.io/builds/10049158/badge)](https://coveralls.io/builds/10049158)

          Coverage decreased (-0.005%) to 31.311% when pulling *b271e30a2da3e0972f95d6c3b29e05f89584a71c on dongeforever:ROCKETMQ-83* into *e6aaedcf4d23f95791c51fb510baf369c8b1f5c1 on apache:master*.

          githubbot ASF GitHub Bot added a comment -

          Github user coveralls commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          [![Coverage Status](https://coveralls.io/builds/10049158/badge)](https://coveralls.io/builds/10049158)

          Coverage decreased (-0.005%) to 31.311% when pulling *b271e30a2da3e0972f95d6c3b29e05f89584a71c on dongeforever:ROCKETMQ-83* into *e6aaedcf4d23f95791c51fb510baf369c8b1f5c1 on apache:master*.

          githubbot ASF GitHub Bot added a comment -

          Github user coveralls commented on the issue:

          https://github.com/apache/incubator-rocketmq/pull/54

          [![Coverage Status](https://coveralls.io/builds/10049158/badge)](https://coveralls.io/builds/10049158)

          Coverage decreased (-0.005%) to 31.311% when pulling *b271e30a2da3e0972f95d6c3b29e05f89584a71c on dongeforever:ROCKETMQ-83* into *e6aaedcf4d23f95791c51fb510baf369c8b1f5c1 on apache:master*.

          jira-bot ASF subversion and git services added a comment -

          Commit bd008546b88cf862879c5ce1fb48b537d4f06f53 in incubator-rocketmq's branch refs/heads/master from dongeforever
          [ https://git-wip-us.apache.org/repos/asf?p=incubator-rocketmq.git;h=bd00854 ]

          ROCKETMQ-83 Fix quick start, annotate setNamesrvAddr, closes apache/incubator-rocketmq#54

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/incubator-rocketmq/pull/54

          jira-bot ASF subversion and git services added a comment -

          Commit bd008546b88cf862879c5ce1fb48b537d4f06f53 in incubator-rocketmq's branch refs/heads/release-4.0.0-incubating from dongeforever
          [ https://git-wip-us.apache.org/repos/asf?p=incubator-rocketmq.git;h=bd00854 ]

          ROCKETMQ-83 Fix quick start, annotate setNamesrvAddr, closes apache/incubator-rocketmq#54


            People

            • Assignee:
              Yukon yukon
              Reporter:
              djkooks Kwang-in (Dennis) JUNG
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development