A pair of getter/setter has inconsistent names: getName() and setType() in RangerServiceDef. This should be fixed to be consistent.
Though 'type' seems to be a better choice than name for ServiceDefs, to minimize the number of references that needs to be updated, it will be easier to change setType() to setName(). Changing 'name' to 'type' would require changes across a lot of files - including service-def JSON files.
So I propose to rename RangerServiceDef.setType() to RangerServiceDef.setName().