Uploaded image for project: 'Ranger'
  1. Ranger
  2. RANGER-348

Allow ranger admin install with JDK 1.8

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.5.0
    • Component/s: None
    • Labels:
      None

      Description

      Ranger admin installation requires JDK 1.7. It should allow JDK 1.8 also.

      If JDK 1.8 is used, it fails with the below error.

      [2015/03/16 10:25:06]: [I] uname=Linux
      [2015/03/16 10:25:06]: [I] hostname=c6401.ambari.apache.org
      [2015/03/16 10:25:06]: [I] DB_FLAVOR=MYSQL
      [2015/03/16 10:25:07]: [I] Checking distribution name..
      [2015/03/16 10:25:07]: [I] Found distribution : CentOS
      [2015/03/16 10:25:07]: [I] check if command /usr/jdk64/jdk1.8.0_40/bin/java exists
      [2015/03/16 10:25:07]: [I] '/usr/jdk64/jdk1.8.0_40/bin/java' command found
      [2015/03/16 10:25:07]: [E] Java 1.7 is required

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vel Velmurugan Periasamy
                Reporter:
                vel Velmurugan Periasamy
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: