Uploaded image for project: 'Ranger'
  1. Ranger
  2. RANGER-215

ranger virtual package dependency broken

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Invalid
    • Affects Version/s: 0.4.0
    • Fix Version/s: 0.5.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      HDP 2.2

      Description

      This might technically be a Hortonworks packaging fault...

      yum install ranger
      Loaded plugins: rhnplugin, security
      This system is receiving updates from RHN Classic or RHN Satellite.
      Setting up Install Process
      Resolving Dependencies
      --> Running transaction check
      ---> Package ranger.noarch 0:0.4.0.2.2.0.0-2041.el6 will be installed
      --> Processing Dependency: ranger_2_2_0_0_2041 for package: ranger-0.4.0.2.2.0.0-2041.el6.noarch
      --> Finished Dependency Resolution
      Error: Package: ranger-0.4.0.2.2.0.0-2041.el6.noarch (HDP-2.2)
                 Requires: ranger_2_2_0_0_2041
       You could try using --skip-broken to work around the problem
       You could try running: rpm -Va --nofiles --nodigest
      

      I worked around by installing components such as ranger-admin and ranger-usersync directly.

      Regards,

      Hari Sekhon
      http://www.linkedin.com/in/harisekhon

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              harisekhon Hari Sekhon
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: