Uploaded image for project: 'Ranger'
  1. Ranger
  2. RANGER-1935

Upgrade Ranger to support Apache Hadoop 3.0.0

    Details

    • Type: Improvement
    • Status: Patch Available
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 2.0.0
    • Component/s: plugins
    • Labels:
      None

      Description

      This task is to upgrade Ranger to support Apache Hadoop 3.0.0. Here are some notes about the upgrade:

      a) The Hive plugin needs the Hadoop 3.0.0 jars to run the tests properly, as Hive only supports the older Hadoop version, so an exclusion and some additional 3.0.0 dependencies need to be added.
      b) The Storm plugin bundles the hadoop-auth jars in storm-core (although they really should be renamed here). Therefore, we have no option but to package Storm with the Hadoop 2.7.x jars, until such time that Storm upgrades the Hadoop dependency.

      This is an initial patch to get some feedback. If there is broad agreement on the upgrade I will test the distributions properly.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                coheigea Colm O hEigeartaigh
                Reporter:
                coheigea Colm O hEigeartaigh
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: