Uploaded image for project: 'Ranger'
  1. Ranger
  2. RANGER-1484

RangerUI: Escape of policy condition text entered in the policy form.

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.7.0
    • Fix Version/s: 1.0.0, 0.7.1
    • Component/s: Ranger
    • Labels:
      None

      Description

      The text entered in policy condition UI comes back with escape characters after saving the policy.

      For example: 
      1.create policy with policy condition as “tag.attributes['type']=='ccn'” .
      2.Now open that policy in edit mode you will see policy condition 
      becomes "tag.attributes['type']=='ccn'".
      

      Another issue is that UI displays policy conditions that don’t have any value.Only the condition edit popup would list all the conditions; the policy view would only list the conditions that have non-empty value.
      See attachments for more info: image001.png, image002.png.

        Attachments

        1. image001.png
          40 kB
          Nitin Galave
        2. image002.png
          38 kB
          Nitin Galave
        3. RANGER-1484.patch
          2 kB
          Nitin Galave

          Issue Links

            Activity

              People

              • Assignee:
                nitin.galave Nitin Galave
                Reporter:
                madhan Madhan Neethiraj
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: