Uploaded image for project: 'Ranger'
  1. Ranger
  2. RANGER-1405

groups are not shown if exact user name is passed in search filter

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 0.7.0
    • 1.0.0, 0.7.1
    • Ranger
    • None

    Description

      groups are not shown if exact user name is passed in search filter
      scenario:
      1) user abc is mapped with "abc","users", "newgroup"
      2) make rest call to fetch all the users or go to UI and see all the users and look for abc
      https://<rangeradmin>:6182/service/xusers/users?pageSize=500
      mapping is shown properly through both rest call and UI
      3) now filter the users with username filter "abc" or try same with following rest call
      https://<rangeradmin>:6182/service/xusers/users?pageSize=500&name=abc
      ER: group should be shown associated with user abc
      AR: no group association is shown for user abc after applying filter

      Attachments

        1. RANGER-1405.patch
          22 kB
          Mehul Parikh
        2. RANGER-1405.1.patch
          25 kB
          Mehul Parikh
        3. RANGER-1405.2.patch
          25 kB
          Mehul Parikh
        4. RANGER-1405.3.patch
          19 kB
          Mehul Parikh

        Activity

          People

            mehul Mehul Parikh
            deepakhuawei Deepak Sharma
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: