Uploaded image for project: 'Qpid JMS'
  1. Qpid JMS
  2. QPIDJMS-540

Target Java 11+ , i.e. drop support for Java 8 [/9/10]

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.0
    • Component/s: qpid-jms-client
    • Labels:
      None

      Description

      Begin targeting Java 11 from the 1.0.0 release off the main branch, i.e start requiring Java 11+ to build or use the client and drop support for Java 8 [/9/10] for 1.0.0+.

      The 0.x stream can be used for Java 8 support, with occasional releases for important issues possible for a period of time, e.g a year. A 0.59.0 release will be performed alongside the 1.0.0 release.

      As discussed on the mailing list last month:
      https://lists.apache.org/thread.html/r1558d5f402ac1cecd0785be72c441d1a034e3c49f72dbfdcd02d5f8c%40%3Cusers.qpid.apache.org%3E

        Attachments

          Activity

            People

            • Assignee:
              robbie Robbie Gemmell
              Reporter:
              robbie Robbie Gemmell

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment