Qpid
  1. Qpid
  2. QPID-730

.Net shows message count and queue depth 0 on durable subscription at first connect.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: M2
    • Fix Version/s: M2.1
    • Component/s: Dot Net Client
    • Labels:
      None

      Description

      First of all, I am able to write to the durable queue with no consumers. In the management console (MC) I see the message count increment and the queue depth increase. I then create my consumer on the queue expecting to receive an initial burst of subscription data for the queued messages. However, what happens is at the point I create the consumer on the queue, the message count and queue depth get set to zero.

      Is this just the pre-fetch buffer emptying the queue? Need to look into and give Robert Popple an answer on this.

        Activity

        Justin Ross made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Gavin made changes -
        Workflow QPid [ 12438683 ] QPid Workflow [ 12439965 ]
        Gavin made changes -
        Workflow jira [ 12420687 ] QPid [ 12438683 ]
        Aidan Skinner made changes -
        Field Original Value New Value
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Rupert Smith created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Rupert Smith
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development