Qpid
  1. Qpid
  2. QPID-5338

The Dispatch top-level Python package should be renamed

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Future
    • Component/s: Qpid Dispatch
    • Labels:
      None

      Description

      Currently the package name is qpid, which conflicts with the public qpid Python package library. A better idea would be to rename it qpiddx.

        Activity

        Hide
        ASF subversion and git services added a comment -

        Commit 1541585 from Darryl L. Pierce in branch 'dispatch/trunk'
        [ https://svn.apache.org/r1541585 ]

        QPID-5338: Renamed the top Python package to qpiddx.

        This fixes the collision between the embedded library's name and the
        public Qpid Python libraries.

        Show
        ASF subversion and git services added a comment - Commit 1541585 from Darryl L. Pierce in branch 'dispatch/trunk' [ https://svn.apache.org/r1541585 ] QPID-5338 : Renamed the top Python package to qpiddx. This fixes the collision between the embedded library's name and the public Qpid Python libraries.
        Hide
        ASF subversion and git services added a comment -

        Commit 1541589 from Darryl L. Pierce in branch 'dispatch/trunk'
        [ https://svn.apache.org/r1541589 ]

        QPID-5338: Added ChangeLog entry

        Show
        ASF subversion and git services added a comment - Commit 1541589 from Darryl L. Pierce in branch 'dispatch/trunk' [ https://svn.apache.org/r1541589 ] QPID-5338 : Added ChangeLog entry
        Hide
        ASF subversion and git services added a comment -

        Commit 1541931 from Darryl L. Pierce in branch 'dispatch/trunk'
        [ https://svn.apache.org/r1541931 ]

        QPID-5338: Removed the dispatch package from under qpiddx

        The package was redundant.

        Show
        ASF subversion and git services added a comment - Commit 1541931 from Darryl L. Pierce in branch 'dispatch/trunk' [ https://svn.apache.org/r1541931 ] QPID-5338 : Removed the dispatch package from under qpiddx The package was redundant.
        Hide
        Justin Ross added a comment -

        The C code is under include/qpid/dispatch/. Wouldn't the python analog be "qpid_dispatch"? For me, that also more sensibly matches the pattern with qpid_messaging.

        By the way, you left a bunch of empty directories in the subversion tree.

        Show
        Justin Ross added a comment - The C code is under include/qpid/dispatch/. Wouldn't the python analog be "qpid_dispatch"? For me, that also more sensibly matches the pattern with qpid_messaging. By the way, you left a bunch of empty directories in the subversion tree.
        Hide
        Darryl L. Pierce added a comment -

        The package naming convention discourages using underscores [1]. That said, the name for the package IMO so much about the directory tree for the sources as it is a namespace to avoid collisions with other Python code.

        Sorry about the empty directories, it's a git->svn glitch that I'll clean that up shortly.

        [1] http://www.python.org/dev/peps/pep-0008/#package-and-module-names

        Show
        Darryl L. Pierce added a comment - The package naming convention discourages using underscores [1] . That said, the name for the package IMO so much about the directory tree for the sources as it is a namespace to avoid collisions with other Python code. Sorry about the empty directories, it's a git->svn glitch that I'll clean that up shortly. [1] http://www.python.org/dev/peps/pep-0008/#package-and-module-names
        Hide
        ASF subversion and git services added a comment -

        Commit 1542364 from Darryl L. Pierce in branch 'dispatch/trunk'
        [ https://svn.apache.org/r1542364 ]

        QPID-5338: Removing empty directories left behind by git.

        Show
        ASF subversion and git services added a comment - Commit 1542364 from Darryl L. Pierce in branch 'dispatch/trunk' [ https://svn.apache.org/r1542364 ] QPID-5338 : Removing empty directories left behind by git.
        Hide
        Justin Ross added a comment -

        Yes, I know about that naming convention. I mentioned it to you before you chose qpid*_*messaging for the python binding. At any rate, the guideline does in the end allow for underscores in the name. We should stick to the pattern we have.

        It's not just a namespace. We could have qpidbananas and qpidclowns if we just wanted to avoid a collision. Let's save our users having to remember one more needless difference.

        Show
        Justin Ross added a comment - Yes, I know about that naming convention. I mentioned it to you before you chose qpid*_*messaging for the python binding. At any rate, the guideline does in the end allow for underscores in the name. We should stick to the pattern we have. It's not just a namespace. We could have qpidbananas and qpidclowns if we just wanted to avoid a collision. Let's save our users having to remember one more needless difference.
        Hide
        Justin Ross added a comment -

        You need to remove qpiddx/dispatch as well.

        Show
        Justin Ross added a comment - You need to remove qpiddx/dispatch as well.
        Hide
        Darryl L. Pierce added a comment -

        I'm fine then with whatever's decided.

        Show
        Darryl L. Pierce added a comment - I'm fine then with whatever's decided.

          People

          • Assignee:
            Darryl L. Pierce
            Reporter:
            Darryl L. Pierce
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development