Qpid
  1. Qpid
  2. QPID-5014

Make autotools build require special argument to work

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.24
    • Component/s: Build Tools
    • Labels:
      None

      Description

      autotools builds have been deprecated and will be removed in 0.26. To make sure that users really notice this we will stop the autotools build from working by default in 0.24.

      It will require the user to specify specifically that they want to use the deprecated build system before autotools builds will run.

        Issue Links

          Activity

          Hide
          ASF subversion and git services added a comment -

          Commit 1506694 from Andrew Stitcher in branch 'qpid/trunk'
          [ https://svn.apache.org/r1506694 ]

          QPID-5014: Require "--enable-deprecated-autotools" to use autotools

          Show
          ASF subversion and git services added a comment - Commit 1506694 from Andrew Stitcher in branch 'qpid/trunk' [ https://svn.apache.org/r1506694 ] QPID-5014 : Require "--enable-deprecated-autotools" to use autotools
          Hide
          Andrew Stitcher added a comment -

          This change has now been committed to trunk:

          [It is only on trunk very temporarily to allow better review, for inclusion to the 0.24 branch, and will obviously go away when the autotools build system is removed]

          The required argument is "--enable-deprecated-autotools"

          Show
          Andrew Stitcher added a comment - This change has now been committed to trunk: [It is only on trunk very temporarily to allow better review, for inclusion to the 0.24 branch, and will obviously go away when the autotools build system is removed] The required argument is "--enable-deprecated-autotools"
          Hide
          Alan Conway added a comment -

          Reviewed and approved for 0.24

          Show
          Alan Conway added a comment - Reviewed and approved for 0.24
          Hide
          Justin Ross added a comment -

          Reviewed by Alan. Approved for 0.24.

          Show
          Justin Ross added a comment - Reviewed by Alan. Approved for 0.24.
          Hide
          ASF subversion and git services added a comment -

          Commit 1507121 from Andrew Stitcher in branch 'qpid/branches/0'
          [ https://svn.apache.org/r1507121 ]

          QPID-5014: Require "--enable-deprecated-autotools" to use autotools

          Show
          ASF subversion and git services added a comment - Commit 1507121 from Andrew Stitcher in branch 'qpid/branches/0' [ https://svn.apache.org/r1507121 ] QPID-5014 : Require "--enable-deprecated-autotools" to use autotools
          Hide
          Justin Ross added a comment -
          Show
          Justin Ross added a comment - Released in Qpid 0.24, http://qpid.apache.org/releases/qpid-0.24/index.html

            People

            • Assignee:
              Andrew Stitcher
              Reporter:
              Andrew Stitcher
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development